Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Problem running web app

  1. #1
    Join Date
    May 2002
    Posts
    1

    Default Problem running web app

    Hello there
    I am using Mondrian with mysql. How I can configure the Jdbc connection?
    After compiling the application (with no errors) when i try to execute
    http://localhost:8080/mondrian
    the tomcat send me an error message 404 (the requested resource is not available).
    Can You help me ?

  2. #2
    Join Date
    Nov 1999
    Posts
    1,618

    Default RE: Problem running web app

    I'm not sure the problem is with jdbc.
    Did you start tomcat? Try going to
    http://localhost:8080/mondrian/index.jsp
    or
    http://localhost:8080/mondrian/taglib.jsp.

  3. #3
    Join Date
    Feb 2004
    Posts
    14

    Default RE: Problem running web app

    I ran into the same problem.
    The index.jsp is not found either.
    I built mondrian like pjtallman described it. The only difference is that I do not use servlet-api.jar and jsp-api.jar, but servlet.jar from tomcat 4.1.29.

  4. #4
    Join Date
    Feb 2004
    Posts
    14

    Default RE: Problem running web app

    ...
    and it seems like I do not get it solved.
    Is there anything known about a solution?
    Or does anyone know where to look?

  5. #5

    Default RE: Problem running web app

    Hello Paolo, I had the same problem a few months ago and the solution was to modify a source file that had the jdbc source hardcoded.
    If you give me some time I'll try to find which file did I have to modify. I'm not sure because it was some time ago, but I think that it had the Access jdbc hardcoded.
    Regards,
    --Claudio

  6. #6

    Default RE: Problem running web app

    It seems to be a jpivot issue.
    jpivot.war has this hardcoded, and when you install it, it generates the file $CATALINA_HOME/webapps/mondrian/WEB-INF/queries/mondrian.jsp that has
    jdbcDriver="sun.jdbc.odbc.JdbcOdbcDriver"
    and
    jdbcUrl="jdbcdbc:MondrianFoodMart"
    For using with mysql you should change it to:
    jdbcDriver="com.mysql.jdbc.Driver"
    and
    jdbcUrl="jdbc:mysql://localhost/foodmart?user=foodmart&password=foodmart"
    Hope this helps.
    Regards,
    --Claudio

  7. #7
    Join Date
    Feb 2004
    Posts
    14

    Default solved

    I upgraded ant from 1.5.4 to 1.6.1 and now the problem with the 404 is gone.
    Of course I ran into a new one, but this was obviously caused by ant.

  8. #8
    Join Date
    Jan 2004
    Posts
    10

    Default RE: Problem running web app

    A hack around this is to deploy Mondrian. Then stop Tomcat. Manually edit the Mondrian.jsp, Fourheir.jsp, and trendarrows.jsp. Then clear the Tomcat cache (%TOMCAT_DIR%\work\Catalina\localhost\mondrian) and restart tomcat.
    We went ahead and automated this by creating an ant replace task to do the updates for us.
    --Pat

  9. #9
    Join Date
    Mar 2004
    Posts
    9

    Default RE: Problem running web app

    I have the same problem, and I notice that the file trendarrows.jsp don't exist, And I have the same error 404 when run it, but notice that that error is because some files where not deployed, files *.tdl two of them, (If you read the log of the tomcat You can see what file are), conclusion, the compilation made a bad war file Some one can really tellme how compile this with mysql, I been trying for more than a week, thank

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.