Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Junit error during Rolap connection

  1. #1
    Join Date
    Dec 2002
    Posts
    4

    Default Junit error during Rolap connection

    Hi,
    I created my own servler to display demo data (FoodMart).
    I got error "Error: junit/framework/Test " during :
    DriverManager.getConnection(connectString, null, false);
    My connectString is correct (tested with Demo servlet)
    Could you help me ? I don't understand how Junit is invloced in my code.
    Olivier

  2. #2
    Join Date
    Nov 1999
    Posts
    1,618

    Default RE: Junit error during Rolap connection

    Suspect that this is a linking error, because JUnit is not on your classpath. We don't call JUnit at runtime, but some of the classes have dependencies on it, and will therefore fail to load if you don't have JUnit.
    Add Junit.jar to your classpath, and try it again. Please let me know if this works.

  3. #3
    Join Date
    Dec 2002
    Posts
    4

    Default RE: Junit error during Rolap connection

    Yeah, it worked, thanks.
    Now I have a
    Error: Internal error: Failed to parse query [select {[Measures].[Unit Sales]} on
    columns from Sales]
    I gonna investigate, but it looks better.
    THANKS!

  4. #4
    Join Date
    Nov 1999
    Posts
    1,618

    Default RE: Junit error during Rolap connection

    First thing I would check is the URL to FoodMart.xml.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.