Hitachi Vantara Pentaho Community Forums
Results 1 to 10 of 10

Thread: Kettle tools won't run on Windows (FIXED)

  1. #1
    Join Date
    Nov 1999
    Posts
    9,729

    Default RE: Kettle tools won't run on Windows

    Mmm, I'm sure I tested it on just about every windows version around.
    You're not running any special VM are you?
    Can you give some more info on your setup?


    Thanks, Matt

  2. #2
    Join Date
    Sep 2005
    Posts
    1,403

    Default RE: Kettle tools won't run on Windows

    Same to me. Seems to me it's compiled with Java 1.5, isn't it?


    Thomas

  3. #3
    Join Date
    Sep 2005
    Posts
    1,403

    Default RE: Kettle tools won't run on Windows

    I am running on Windows 2000 Server, and I tried jdk1.4.2_07 and jdk1.5.0_06, both from Sun.

  4. #4
    Join Date
    Sep 2005
    Posts
    1,403

    Default RE: Kettle tools won't run on Windows

    I'm using jdk1.4.2_06. When i changed the remarking of the last two lines in spoon.bat
    I got at this exception:


    Exception in thread "main" java.lang.UnsupportedClassVersionError: be/ibridge/ke
    ttle/spoon/Spoon (Unsupported major.minor version 49.0)
    at java.lang.ClassLoader.defineClass0(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)



    Based on this message I'm assuming a version conflict.
    Are you shure running jdk1.5?

  5. #5
    Join Date
    Nov 1999
    Posts
    9,729

    Default RE: Kettle tools won't run on Windows

    >I am starting it with jdk1.5.0_06 (verified at command line). I get the error message "Could not find main class".

    Well actually, usually I'm compiling with 1.4.2 to stay as compatible as possible, but I'm guessing that the auto-build from javaForge is running with 1.5.0
    I'll force the target of kettle.jar to 1.4 later tonight in build.xml

    Boy, that'll teach me to remove all those enum variables... at least I would have gotten an error now.

    To be fair, I noticed in the ant documentation this little warning printed in bold convercerning the target attribute: We highly recommend to always specify this attribute.

    My suggestion if you want to look further before 21:00CET: check out the source and do an "ant zip"
    This generates the kettle-2.2.0.zip file.

    Cheers,

    Matt

  6. #6
    Join Date
    Nov 1999
    Posts
    9,729

    Default RE: Kettle tools won't run on Windows

    I re-compiled the whole Kettle codebase using target="1.4" source="1.4".

    Can anyone try to download the new kettle.jar and see if it works on JRE 1.4?
    (it works fine for me)

    Thanks,

    Matt

  7. #7
    Join Date
    Sep 2005
    Posts
    1,403

    Default RE: Kettle tools won't run on Windows

    Matt,

    now it works for me (jdk1.4.2_06), thanks.

    BTW, skimming the docs I found some contradictions in Pan-2.2.pdf at page 3: Is this manual about Pan as titled or about Chef (see page header) or about Spoon (see 1.3) ? ;-)

    Thomas

  8. #8
    Join Date
    Nov 1999
    Posts
    9,729

    Default RE: Kettle tools won't run on Windows

    Hehe, the Pan documentation was more of an afterthought.
    I show the options now when you run Pan.bat (or pan.sh)

    Opened bug - [# 1314] Pan documentation correction

    Thanks,

    Matt

  9. #9
    Join Date
    Sep 2005
    Posts
    1,403

    Default RE: Kettle tools won't run on Windows

    Now it works for me too, thanks. Looks like a great piece of software, as far as I could see up to now

  10. #10
    Join Date
    Nov 1999
    Posts
    9,729

    Default Kettle tools won't run on Windows (FIXED)

    I unzipped the kettle-2.2.0.zip file I downloaded from your site. When I start the Spoon.bat file from the main directory, I get an error message saying "Cannot find main class" and the program exits. Tried several adjustments to the bat-file by inserting absolute paths for classpath etc. but nothing works.


    Any idea?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.