Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Problems running Pan under Windows

  1. #1
    Join Date
    Jan 2006
    Posts
    14

    Default Problems running Pan under Windows

    I've tried running my transformation (which works great in Spoon, and in Pan on Linux) from Windows using the pan.bat script, and as noted in another forum post, surrounded options with double quotes; I still get "Transformation cannot be loaded" errors:

    In the following, 'sitedbtest.ktr' is the XML export of my transformation from a repository 'kettlerep' in a (local) MySQL database.

    No quotes:
    C:\work\cnet\kettle>pan -file=sitedbtest.ktr -level=Basic
    2006/01/23 14:52:18.406 - Pan - Start of run.
    2006/01/23 14:52:18.671 - DBCache - Loading database cache from file: [C:\Documents and Settings\avitous\.kettle\db.cache]
    ERROR: Pan can't continue because the transformation couldn't be loaded.

    With quotes:
    C:\work\cnet\kettle>pan -file="sitedbtest.ktr" -level=Basic
    2006/01/23 14:54:33.031 - Pan - Start of run.
    2006/01/23 14:54:33.250 - DBCache - Loading database cache from file: [C:\Documents and Settings\avitous\.kettle\db.cache]
    ERROR: Pan can't continue because the transformation couldn't be loaded.

    Also tried specifying transformation from repository:
    C:\work\cnet\kettle>pan -rep="kettlerep" -trans="sitedbtest" -dir="" -user="admin" -pass="admin" -level=Basic
    2006/01/23 14:43:19.343 - Pan - Start of run.
    2006/01/23 14:43:19.609 - DBCache - Loading database cache from file: [C:\Documents and Settings\avitous\.kettle\db.cache]
    ERROR: Pan can't continue because the transformation couldn't be loaded.

    Tried using forward-slash for directory:
    C:\work\cnet\kettle>pan -rep="kettlerep" -trans="sitedbtest" -dir="/" -user="admin" -pass="admin" -level=Basic
    2006/01/23 14:43:44.796 - Pan - Start of run.
    2006/01/23 14:43:45.062 - DBCache - Loading database cache from file: [C:\Documents and Settings\avitous\.kettle\db.cache]
    ERROR: Pan can't continue because the transformation couldn't be loaded.

    Copied the transformation XML 'sitedbtest.ktr' to a Linux box on which I also have Kettle 2.2.1 installed, and it runs great:
    $ ./pan.sh -file=sitedbtest.ktr -level=Basic
    (messages omitted, but ran perfectly)

    Based on my reading of docs I seem to be trying to invoke Pan correctly; am I missing something here?

    Thanks,
    Anderson

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default RE: Problems running Pan under Windows

    Hi Anderson,

    It's a comon problem and this has been fixed in 2.2.2:

    Use :

    pan "-file=transfile.ktr"

    Even this doesn't work for everyone for some reason (NT4 for example), so with the new 2.2.2. it's

    pan /file:transfile.ktr

    It's the stupid behavior of the MS-DOS prompt that is the cause of the whole mess.
    1) mangling of = and - characters
    2) limit of MS-DOS to 10 arguments

    Good luck,

    Matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.