Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: unable to read from repositories

  1. #1
    Join Date
    Sep 2005
    Posts
    1,403

    Default unable to read from repositories

    Hi,
    I am using Keetle2.2.1, Java1.4.2_04 and the Window XP version 2002 with Pentium4 3GHz,504 MB of RAM. When I start the keetle, after verifying the admin password it gives me the error as "Unable to read the transformation from repository" and a big list of java errors





    An error occured reading a transformation from the repository



    Unexpected error reading step information from the repository
    at be.ibridge.kettle.spoon.Spoon.main (null:-1)
    at be.ibridge.kettle.trans.dialog.TransLoadProgressDialog.open (null:-1)
    at org.eclipse.jface.dialogs.ProgressMonitorDialog.run (ProgressMonitorDialog.java:447)
    at org.eclipse.jface.operation.ModalContext.run (ModalContext.java:291)
    at org.eclipse.jface.operation.ModalContext.runInCurrentThread (ModalContext.java:346)
    at be.ibridge.kettle.trans.dialog.TransLoadProgressDialog$1.run (null:-1)
    at be.ibridge.kettle.trans.TransMeta.<init> (null:-1)
    at be.ibridge.kettle.trans.step.StepMeta.<init> (null:-1)
    at be.ibridge.kettle.trans.step.joinrows.JoinRowsMeta.readRep (null:-1)
    at be.ibridge.kettle.core.Condition.<init> (null:-1)









    java.lang.reflect.InvocationTargetException: Error loading transformation
    at be.ibridge.kettle.trans.dialog.TransLoadProgressDialog$1.run(Unknown Source)
    at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:346)
    at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:291)
    at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:447)
    at be.ibridge.kettle.trans.dialog.TransLoadProgressDialog.open(Unknown Source)
    at be.ibridge.kettle.spoon.Spoon.main(Unknown Source)
    Caused by: be.ibridge.kettle.core.exception.KettleException:
    An error occured reading a transformation from the repository



    Unexpected error reading step information from the repository
    at be.ibridge.kettle.spoon.Spoon.main (null:-1)
    at be.ibridge.kettle.trans.dialog.TransLoadProgressDialog.open (null:-1)
    at org.eclipse.jface.dialogs.ProgressMonitorDialog.run (ProgressMonitorDialog.java:447)
    at org.eclipse.jface.operation.ModalContext.run (ModalContext.java:291)
    at org.eclipse.jface.operation.ModalContext.runInCurrentThread (ModalContext.java:346)
    at be.ibridge.kettle.trans.dialog.TransLoadProgressDialog$1.run (null:-1)
    at be.ibridge.kettle.trans.TransMeta.<init> (null:-1)
    at be.ibridge.kettle.trans.step.StepMeta.<init> (null:-1)
    at be.ibridge.kettle.trans.step.joinrows.JoinRowsMeta.readRep (null:-1)
    at be.ibridge.kettle.core.Condition.<init> (null:-1)






    at be.ibridge.kettle.trans.TransMeta.<init>(Unknown Source)
    ... 6 more
    Caused by: be.ibridge.kettle.core.exception.KettleException:
    Unexpected error reading step information from the repository
    at be.ibridge.kettle.spoon.Spoon.main (null:-1)
    at be.ibridge.kettle.trans.dialog.TransLoadProgressDialog.open (null:-1)
    at org.eclipse.jface.dialogs.ProgressMonitorDialog.run (ProgressMonitorDialog.java:447)
    at org.eclipse.jface.operation.ModalContext.run (ModalContext.java:291)
    at org.eclipse.jface.operation.ModalContext.runInCurrentThread (ModalContext.java:346)
    at be.ibridge.kettle.trans.dialog.TransLoadProgressDialog$1.run (null:-1)
    at be.ibridge.kettle.trans.TransMeta.<init> (null:-1)
    at be.ibridge.kettle.trans.step.StepMeta.<init> (null:-1)
    at be.ibridge.kettle.trans.step.joinrows.JoinRowsMeta.readRep (null:-1)
    at be.ibridge.kettle.core.Condition.<init> (null:-1)



    at be.ibridge.kettle.trans.step.joinrows.JoinRowsMeta.readRep(Unknown Source)
    at be.ibridge.kettle.trans.step.StepMeta.<init>(Unknown Source)
    ... 7 more
    Caused by: java.lang.NullPointerException
    at be.ibridge.kettle.core.Condition.<init>(Unknown Source)
    ... 9 more






    Previously it was working fine. I have tried checking with new repositories and new connection as well. But all my efforts gone in vane. Could you please tell me the cause of the error and the solution as well.



    thanks in advance



    cheers!
    Dinesh Barua
    Indore

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default RE: unable to read from repositories

    Hi Anonymous,

    Thank you for the bug-report. It seems to be a problem in the loading of the Condition in a filter or a join.
    Can you first try to upgrade to version 2.2.2 and see if this fixes the problem?
    If it doesn&#39;t I&#39;ll get a fix for you as soon as possible. Sorry about the inconvenience.

    Best regards,

    Matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.