Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Database Join - Unexpected Error

  1. #1
    Join Date
    Sep 2005
    Posts
    1,403

    Default Database Join - Unexpected Error

    I am doing a Database Join Step and I have verified the SQL is working and previewed the output fields. However when I preview the transformation I get the 'No rows found in previewing this step' with the following log:


    2006/03/10 10:31:13 - Database join.0 - Starting to run...
    2006/03/10 10:31:13 - Database join.0 - ERROR : Unexpected error in part : <u>-</u>
    2006/03/10 10:31:13 - Database join.0 - ERROR : java.lang.IndexOutOfBoundsException: Index: 0, Size: 0



    Also when I run the transformation I get a totally different error:



    2006/03/10 10:33:11 - Database join.0 - ERROR : A database error occurred, stopping everything:
    Error occured while trying to connect to the database



    Error connecting to database: (using class sun.jdbc.odbc.JdbcOdbcDriver)
    Microsoft[img]/wiki/images/newpage.gif[/url]ODBC Driver Manager[img]/wiki/images/newpage.gif[/url] Data source name not found and no default driver specified






    2006/03/10 10:33:11 - be.ibridge.kettle.trans.Trans - ERROR : Error initializing step Database join[img]/wiki/images/newpage.gif[/url]
    2006/03/10 10:33:11 - Text file output.0 - Opening output stream in default encoding
    2006/03/10 10:33:11 - be.ibridge.kettle.trans.Trans - ERROR : We failed to initialize at least one step. Execution can not begin!



    Database connection test returns OK so I do not have connection issues. This may be a bug with the DB connectio since it is trying to lookup an ODBC even thought a native JDBC URL has been specified. I know the DB connection is setup fine since I can execute queries successfully using the SQL Editor window option on the Connections menu.

  2. #2
    Join Date
    Sep 2005
    Posts
    1,403

    Default RE: Database Join - Unexpected Error

    Replying to myself in case somebody finds this useful:


    Database Join does not work with a preceeding step. I added a Generate Rows step prior to db join and it works fine now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.