Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: error while using pan.sh and not pan.bat to run xformation

  1. #1
    Join Date
    Sep 2005
    Posts
    1,403

    Default error while using pan.sh and not pan.bat to run xformation

    HI,


    am trying to run a transformation from cygwin (bash env) with this sommand



    $ ./pan.sh -file:"C:\temptransformation.xml" and get error
    Exception in thread "main" java.lang.NoClassDefFoundError: be/ibridge/kettle/pan
    /Pan



    while i run the same using pan.bat like
    $./pan.bat -file:"c:\temptransformation.xml" is triggering transfomation fine .



    any ideas?



    Thanks,
    sam

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default RE: error while using pan.sh and not pan.bat to run xformation

    Sam,


    The main problem is that there is no Java Virtual Machine that understands the classpath separated by : instead of ;
    The JVM that you are running is the one from Windows.



    Maybe in the future we can compile Classpath for Cygwin or something and then it will work.



    You can make it transparent by calling ./Pan.bat in the script, like it does now but with the command line options passed through and the exit uncommented.



    I just didn't have time to figure out a solution earlier. I'm using Cygwin myself, but in this case I called it quits.



    Hope this clarifies things,



    Matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.