Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Views vs Tables in XActions

  1. #1

    Default Views vs Tables in XActions

    I am using SQL Server DB (2005) as a data source and Pentaho 1.2 RC3. When a simple "select * from my_table" is executed it works fine. When a "select * from my_view" is executed, I get an error that the object does not exist.

    Code:
    Error: SQLBaseComponent.ERROR_0006 - Could not execute qryparam0201.xaction - com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name 'bfa_costs'. (org.pentaho.plugin.sql.SQLLookupRule)
    Debug: Starting execute of epbi/POC/qryparam0201.xaction (org.pentaho.core.solution.SolutionEngine)
    Debug: Getting runtime context and data (org.pentaho.core.solution.SolutionEngine)
    Debug: Loading action sequence definition file (org.pentaho.core.solution.SolutionEngine)
    Debug: SolutionRepository.DEBUG_FILE_PATH - getFile path=W:\temp\pentaho-demoRC3\pentaho-solutions\epbi\POC\qryparam0201.xaction (org.pentaho.repository.filebased.solution.SolutionRepository)
    Debug: audit: instanceId=9f1d3d49-9c28-11db-9c0f-ed92ab8d64ee, objectId=org.pentaho.core.runtime.RuntimeContext, messageType=action_sequence_start (org.pentaho.core.runtime.RuntimeContext)
    Error: SQLBaseComponent.ERROR_0006 - Could not execute qryparam0201.xaction - com.microsoft.sqlserver.jdbc.SQLServerException: Invalid object name 'bfa_costs'. (org.pentaho.plugin.sql.SQLLookupRule)
    Error: RuntimeContext.ERROR_0012 - ActionDefinition for SQLLookupRule did not execute successfully (org.pentaho.core.runtime.RuntimeContext)
    Error: SolutionEngine.ERROR_0007 - Action sequence execution failed (org.pentaho.core.solution.SolutionEngine)
    
     
    
      Server Version 1.2.0 build 470 RC3
    The query works fine when executed in Enterprise Manager. So, the view object does exist.

    Is there some ownership that needs to be identified? dbo.my_view does not work.

    Any thoughts are greatly appreciated.

    I am going to try the same thing with Oracle XE to see if it is just a SQL Server issue.

    Bill
    Last edited by billw; 01-04-2007 at 05:05 PM.

  2. #2

    Exclamation Updates?

    I'm having the same issue. Have you resolved this yet?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.