Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Where to report bugs

  1. #1

    Exclamation Where to report bugs


    It's been asked before, but I didn't find an answer yet. Where should I report bugs?

    In Jira, I need an account, which I cannot get (I get a list of admins when I try to open one). For kettle, there's the javaforge site. But what about the rest of pentaho?


  2. #2
    Join Date
    Jul 2006

    Default Where to report bugs


    I found Kettle bug database, but nothing for the BI platform.

    I'm following the documentation and hitting an UnsatisfiedLinkError and there appears to be no way to report it.

    Anyway, I'm stuck on the bottom of page 11 of "Creating_Pentaho_Solutions-1.2.0GA.pdf" -- "Verfiy that you can test from within the Design Studio" -- but the only thing I can verify is that I can NOT test from within the Design Studio.

    The .log file is attached. The code appears to be referencing swt-mozilla-gtk-3235. I have a file in the plugin named -- I am jumping to the conclusion that the reference needs to be updated to 3305 instead of 3235. Unfortunately I also had trouble setting up the SDK to look into the code.

    If anyone can help me, THANKS.
    Attached Files Attached Files
    • File Type: log .log (19.4 KB, 22 views)

  3. #3
    Join Date
    Nov 2005


    With regard to the problem you're having testing your action sequence from the test page, you may have to configure eclipse to use the proper web browser. From within Eclipse go to Window->Preferences. Under "General" on the left hand side of the preferences dialog select Web Browser. Then select the "Use external Web browser" radio button on the right side and make sure that the "Default system Web browser" check box is selected. If your preferences are already set up to use your default system browser, and you're still not able to test please let me know what you're using as a default system web browser, what version of eclipse you're running and on what platform.
    Last edited by arodriguez; 02-20-2007 at 12:00 PM.

  4. #4
    dmoran Guest


    We are in the process of opening up the case tracking system for entering bugs. Currently it is only available as read only -

    In the mean time, post any bugs to the forum that applies and they will be entered manually.

    This is changing very soon, please stand by...


  5. #5


    No hurry, take your time!

    I think the majority of people was just confused because there was no official statement about how to submit bug reports. For similar situations in the future, I'd suggest an appropriate message on the jira main page, and maybe a sticky note in the forum (or even a dedicated bug reports forum).


  6. #6
    Join Date
    Mar 2007

    Default Having Problem with Unsatisfied Link

    Hello, I am having a similar problem. I am running SUSE Linux 10.1 with eclipse 3.2.1 on an AMD64 platform. The problem arises when I open the HelloWorld action test sequence and click on the 'Test' tab as instructed by the document "Creating_Pentaho_Solutions-1.2.0GA.pdf" mentioned above.

    I get an error that says org.eclipse.swt.SWTError: No more handles (java.lang.UnsatisfiedLinkError: no swt-mozilla-gtk-3235 in java.library.path)

    I verified that jar file containing the missing items is within the plugins directory of the eclipse installation and it was


    Further, I extracted this file to another directory which I then added to it my LD_LIBRARY_PATH. I also added my Mozilla installation /usr/local/mozilla to MOZILLA_FIVE_HOME and the LD_LIBRARY_PATH, but still the same problem.

    Anyone have any idea what is going on?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.