Hitachi Vantara Pentaho Community Forums
Results 1 to 8 of 8

Thread: Field list dropdown in expression not working

  1. #1
    Join Date
    Jan 2007
    Posts
    1

    Exclamation Field list dropdown in expression not working

    Hi all,

    (Cube designer 2.2, Win XP, JRE 1.5.0_10 & JRE 1.6.0, Jaybird for firebird 1.5.3)

    Good job! 1 problem though

    When trying to use the field dropdown list to select a field in the where expression designer tab, the dropdown list flashes quickly and then closes up without letting me select any field.

    Note that I've tried to run the Cube Designer on both JRE 1.5.0_10 and JRE 1.6.0, and none of them solved the problem.

    Also, I think it would be better if we could edit the SQL source manually (no problem if we won't be able to use the designer in this case).

    Any hints?

  2. #2

    Default

    I am getting the same thing, using a PostgreSQL 8.1 connection and Cube Designer running on Windows XP. The Cube Designer version is 0.7. Note that the broken "browse" dropdown and table selector only happens with Postgres. If I select a MySQL connection it is fine.

  3. #3
    Join Date
    Mar 2007
    Posts
    1

    Default Dropdown list error

    Same problem on dropdown list for query creation (closes up too fast, no way to link two tables). Win2K win JDK 1.6.0 & Cube Designer 0.7

  4. #4

    Default

    Pentaho guys, is this CubeDesigner supposed to work with PostgreSQL or not?

  5. #5

    Default

    Quote Originally Posted by CodeMonkey View Post
    Hi all,

    (Cube designer 2.2, Win XP, JRE 1.5.0_10 & JRE 1.6.0, Jaybird for firebird 1.5.3)
    cube designer 2.2? I only see version 0.7 on the download latest tab.... am I missing something?

  6. #6

    Default

    The Cube Designer has been tested with Postgres and should work. I have seen the combo box problem come up when there is a mismatch between the JDBC driver and the version of the Postgres server you are using. Any chance this could be the root of your problem?

    If you are pretty confident that the drivers are correct, try running the Cube Designer with the command window open to see if any errors come up. To do this:

    1) create a shortcut to Cube Designer exe
    2) Modify the Target to look like C:\path\CubeDesigner.exe -vm C:\Sun\SDK\jdk\bin\java.exe

    Use the shortcut to launch the designer and you should see the cmd window appear.

    Note: We will be posting a new build of the designer in a couple of weeks that contains a number of bug fixes. I would love to get your feedback on that as well once it is available.

    Thanks,
    Jake

  7. #7
    Join Date
    Jun 2007
    Posts
    1

    Default

    Hello everybody I'm having the same problem with the combo box. Im using version: 0.7.2 (MILESTONE) and MySql. Did someone found a solution?

    Thanks in advance

    --Edit--
    problem solved downgraded to JDK1.5
    Last edited by ricarce66; 06-17-2007 at 05:15 PM. Reason: Problem solved

  8. #8
    Join Date
    Jul 2007
    Posts
    2,498

    Thumbs down

    Quote Originally Posted by ricarce66 View Post
    problem solved downgraded to JDK1.5

    I can confirm the problem here, and a downgrade also worked. (actually, I had to mess with my JAVA_HOME files, which was kind of annoying)


    Would be great to have this solved.


    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.