Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Shutdown hang

  1. #1
    Join Date
    Sep 2006
    Posts
    28

    Default Shutdown hang

    I've been using Pentaho for a few weeks now, and I've been very pleased. There's one small issue (really just an annoyance) - sometimes, I get a hang during stop-pentaho at the following line:

    Code:
    INFO  [EhCacheManagerFactoryBean] Shutting down EHCache CacheManager
    It happens on 1.5.2 and 1.5.3. It doesn't happen every time, and there doesn't seem to be any particular action or type of action that causes it. But once it happens once, it seems more likely to happen the next time, until I reboot the machine.

    It's not a huge deal, since I can kill the stop-pentaho.bat file and start-pentaho usually works just fine, but I'd like to know if anyone else has noticed this and can point to a more elegant fix.

    Thanks,
    Andy
    Last edited by atkretsch; 03-27-2007 at 05:15 PM. Reason: wanted to set email notification

  2. #2
    Join Date
    Oct 2006
    Posts
    817

    Default

    I've seen this too. I've created PLATFORM-879 in the Pentaho issue tracking system. If you have an opportunity, please adjust your logging (Log4J file in server/default/conf/log4j.xml) to help diagnose the problem. On the first try, I would add the block below to the file. Otherwise, I'd fall back to adding the last block to get the full output for all JBoss classes. But first remove any <param name="Threshold" ... /> elements. Then add <level value="INFO"/> as a child of the <root> element.

    First try this:
    Code:
    <category name="org.pentaho">
      <priority value="DEBUG"/>
    </category>
    As a last resort try this. (Note that this produces lots and lots of output and will be very slow.)
    Code:
    <category name="org.jboss">
      <priority value="DEBUG"/>
    </category>

  3. #3
    Join Date
    May 2006
    Posts
    104

    Default

    I'm having this problem on my WinXP Pro with a freshly installed 1.2.1 Platform using Java 1.5. I did notice that if I didn't actually call up any of the demo's pages in the Browser (MS IE 7), then I could stop-pentaho cleanly. I added the first block to the log4j.xml and restarted the server and called up a page or two. The attachment contains the zipped up logs from jboss/server/default/log. I hope these are the ones you need.
    Last edited by rlance; 07-19-2007 at 03:07 AM.
    Ralph

  4. #4
    Join Date
    Oct 2006
    Posts
    817

    Default

    I couldn't find anything in this log. Can you turn on org.jboss debug logging and post another log?

  5. #5
    Join Date
    May 2006
    Posts
    104

    Default

    Here you go. I brought up Pentaho's Home page and executed only the "Hello World" solution in my browser. After trying to stop pentaho, I did notice that there were errors from DBConnectionFactory that it couldn't connect to the Quartz DB. The stop-pentaho.bat had already closed all the local databases. As it was hanging, I tried to Ctrl-Break a couple of times before hard-closing the command box. BTW, I use the start/stop-pentaho.bat and REMed out the use of the jre under pentaho-demo, so my JDK 1.5.0_11 is used. BTW-II, you may have already noticed, this is all on a german WinXP with the locale-language/country "de/DE" set in the web.xml, if it makes any difference. (We did the translations for the PCI.)
    Attached Files Attached Files
    Ralph

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.