Hitachi Vantara Pentaho Community Forums
Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: This Page cannot be accessed directly

  1. #11
    Join Date
    Jun 2007
    Posts
    11

    Default

    I am seeing:
    Quadrant Headcount Actual and Budget
    This page cannot be accessed directly. It must be linked to from other pages

    pop up in what seems like a random fashion. My JNDI Connection is set up fine, and MOST of the time my cube will display properly. But every so often, it just decides to pop up with the message I pasted in above. I'm using Postgres. I'm going to explore this issue more tomorrow, but just wanted to make an initial post to see if anyone might have any clue what my problem could be.

    Thanks!
    Chris

  2. #12
    Join Date
    Jun 2007
    Posts
    11

    Default

    Ok, so when I first got in this morning the first thing I did was boot up the Pentaho platform and check out my cube. Now, when I first published this cube I left the original in the analysis folder, but also made a copy in a different folder that I made for keeping all of the random projects that I have been working on. So, I initially went to my own folder and clicked on the cube and I got the message about the page cannot be accessed directly. Then, I went to the original copy in the analysis folder and it loaded fine. After that, i went back to the one in my own folder and clicked again... this time it loaded up just fine. I'm thinking something got screwed up when I copied the files over to my folder, but I don't know what! It really seems like I have everything.

    UPDATE: Actually, it doesn't load just fine after I access it from the original folder. It's just loading the last cube that I've accessed. If I go into the steel-wheels folder and click on one of those cubes, and then go back to mine in my folder, it loads up the steel-wheels one. This is really weird!

    Anyway, please let me know if anyone has any ideas! Thanks for the help.
    Chris
    Last edited by Rice; 07-13-2007 at 09:44 AM.

  3. #13
    Join Date
    Jun 2007
    Posts
    11

    Default

    Ok, think I figured it out, or at least I found 1 problem. Even though I copied all of the files to a new folder, it is still looking for the .mondrian.xml file in the analysis folder. So I just put it back in there and it seems to be working well.

  4. #14
    Join Date
    Jul 2007
    Posts
    1

    Default

    Quote Originally Posted by Rice View Post
    I am seeing:
    Quadrant Headcount Actual and Budget
    This page cannot be accessed directly. It must be linked to from other pages

    pop up in what seems like a random fashion. My JNDI Connection is set up fine, and MOST of the time my cube will display properly. But every so often, it just decides to pop up with the message I pasted in above. I'm using Postgres. I'm going to explore this issue more tomorrow, but just wanted to make an initial post to see if anyone might have any clue what my problem could be.

    Thanks!
    Chris
    Hi all,

    >But every so often, it just decides to pop up with the message "This page cannot be accessed >directly. It must be linked to from other pages".

    In spite of the datasource is setup correctly, sometimes the preview fail. Well, we’re to be careful with mondrian file name: if the file name has blanks, the xaction fails because the model tag doesn’t accept blanks in the mondrian file name.

    Antonio

  5. #15

    Default

    Thanks for the feedback Antonio, I've logged that in our defect tracking system and we'll look to address that in the next milestone.

    -Jake

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.