Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Frustrated with NoClassDefFoundError

  1. #1
    Join Date
    Apr 2007
    Posts
    6

    Default Frustrated with NoClassDefFoundError

    I am doing a feasability study on using Pentaho dashboard in our application but I am struck with following error when I am trying to use ant generated pentaho.war for tomcat. I am using 1.5 version. Actually I tried both 1.2 and 1.5 version but the same error and i have seen other posts with the same problem but no solution. Is anybosy using Pentaho with Tomcat or its just a myth.
    I get following error and I think I get this when ever it tries to access the database (hypersonic).

    java.lang.NoClassDefFoundError org.pentaho.repository.runtime.RuntimeRepository.setSession(RuntimeRepository.java:75) org.pentaho.core.system.PentahoSystem.getRuntimeRepository(PentahoSystem.java:1148) org.pentaho.core.solution.SolutionEngineBase.execute(SolutionEngineBase.java:198) org.pentaho.core.solution.SolutionEngineBase.execute(SolutionEngineBase.java:164)

  2. #2

    Question What are you trying to acheive?

    Are you setting-up a dashboard based upon (e.g.) the sample dashboard?

    You may have overspecified your jsp in the web.xml

    You don't need to duplicate all the references to dashboard because some refer to a precompiled class.

    See this thread for more info...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.