Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: RE: 2.5.0 GA (Modified Javascript Step)

  1. #1
    Darren Hartford Guest

    Default RE: 2.5.0 GA (Modified Javascript Step)

    Just a remark - the difference between the 2.4.0 and the 2.5.0 Mod JS
    Step can be confusing (i.e. an existing 2.4.0 ModJS javascript will not
    work in 2.5.0, and vice-versa). There is no identifier to explicitly
    show which version of the Mod JS Step the javascript was written for.

    The improved Mod JS is fine, that isn't the issue. Maybe enhance
    starting 2.5.0 to add some type of identifer? I see a <jsScript_type>
    identifier, not sure if that may be re-usable for this purpose or if a
    new tag could become required starting 2.5.0, and if a new required tag
    is not there, itself lacking is an identifier that it was written for an
    older version ;-).

    Just something to return to the designer/user that the Javascript in a
    KTR file was written for a specific version and may not run on a
    newer/older version of the Mod JS Step.

    usecase:
    2.4.0=
    errortext.setString(MYNUMBER.getInt() + &quot; is not an appropriate
    value&quot;

    2.5.0=
    errortext.setValue(MYNUMBER.getInteger() + &quot; is not an appropriate
    value&quot;

    This was based on the April 25 download of the Kettle jar, not sure if
    there may have been other changes or not. Sorry for the delay in
    reporting.





    ________________________________

    From: kettle-developers (AT) googlegroups (DOT) com
    [mailto:kettle-developers (AT) googlegroups (DOT) com] On Behalf Of Matt Casters
    Sent: Wednesday, April 25, 2007 11:23 AM
    To: 'Lance Walter'; 'Jacob Cornelius';
    kettle-developers (AT) googlegroups (DOT) com; 'Jay Meldrum'; 'Doug Moran'
    Subject: 2.5.0 GA


    Hi Folks,

    I would feel better if we would delay 2.5.0GA for a day or so to
    see what the bug reporting frenzie of the last couple of days is all
    about.
    Some changes have been made the last couple of days to a few
    core classes and I would really like us to do a bit more testing in that
    case.
    Don't get me wrong, this:


    http://www.javaforge.com/displayDocu...p?doc_id=30374

    Is probably the best Kettle release we would ever do, but I
    would prefer just to make sure.

    All the best,

    Matt
    ____________________________________________
    Matt Casters, Chief Data Integration
    Pentaho, Open Source Business Intelligence
    http://www.pentaho.org <http://www.pentaho.org/> --
    mcasters (AT) pentaho (DOT) org
    Tel. +32 (0) 486 97 29 37







    --~--~---------~--~----~------------~-------~--~----~
    You received this message because you are subscribed to the Google Groups "kettle-developers" group.
    To post to this group, send email to kettle-developers (AT) googlegroups (DOT) com
    To unsubscribe from this group, send email to kettle-developers-unsubscribe (AT) g...oups (DOT) com
    For more options, visit this group at http://groups.google.com/group/kettle-developers?hl=en
    -~----------~----~----~----~------~----~------~--~---

  2. #2
    Matt Casters Guest

    Default RE: 2.5.0 GA (Modified Javascript Step)

    Hi Darren,

    I think we just need to document this change correctly.

    Sven B and I agreed that preserving backward compatibility for this
    step would turn out to become very messy in the end.

    All in all, we're talking about 2 or 3 methods that changed. Perhaps
    we can add those as well to the Value class. Don't worry about being
    late. It's because of these things that we've delayed 2.5.0. We'll
    just keep the knowledge we gain from the current "release methodology"
    and take it with us to the next.

    All in all, what I noticed when talking with people at the MySQL
    conference is that a lot of times, our users are still working on
    version 2.3.x. In a lot of situations, they seem to be fine with
    these older releases. It's only when they hit a bug or problem that
    they upgrade. As such, the version 2.5.0 release can stand a little
    delay and will only become better to age more gracefully later on.

    We'll re-evaluate the JS_mod step.

    All the best,

    Matt



    Quoting Darren Hartford <dhartford (AT) ghsinc (DOT) com>:

    > Just a remark - the difference between the 2.4.0 and the 2.5.0 Mod JS
    > Step can be confusing (i.e. an existing 2.4.0 ModJS javascript will not
    > work in 2.5.0, and vice-versa). There is no identifier to explicitly
    > show which version of the Mod JS Step the javascript was written for.
    >
    > The improved Mod JS is fine, that isn't the issue. Maybe enhance
    > starting 2.5.0 to add some type of identifer? I see a <jsScript_type>
    > identifier, not sure if that may be re-usable for this purpose or if a
    > new tag could become required starting 2.5.0, and if a new required tag
    > is not there, itself lacking is an identifier that it was written for an
    > older version ;-).
    >
    > Just something to return to the designer/user that the Javascript in a
    > KTR file was written for a specific version and may not run on a
    > newer/older version of the Mod JS Step.
    >
    > usecase:
    > 2.4.0=
    > errortext.setString(MYNUMBER.getInt() + &quot; is not an appropriate
    > value&quot;
    >
    > 2.5.0=
    > errortext.setValue(MYNUMBER.getInteger() + &quot; is not an appropriate
    > value&quot;
    >
    > This was based on the April 25 download of the Kettle jar, not sure if
    > there may have been other changes or not. Sorry for the delay in
    > reporting.
    >
    >
    >
    >
    >
    > ________________________________
    >
    > From: kettle-developers (AT) googlegroups (DOT) com
    > [mailto:kettle-developers (AT) googlegroups (DOT) com] On Behalf Of Matt Casters
    > Sent: Wednesday, April 25, 2007 11:23 AM
    > To: 'Lance Walter'; 'Jacob Cornelius';
    > kettle-developers (AT) googlegroups (DOT) com; 'Jay Meldrum'; 'Doug Moran'
    > Subject: 2.5.0 GA
    >
    >
    > Hi Folks,
    >
    > I would feel better if we would delay 2.5.0GA for a day or so to
    > see what the bug reporting frenzie of the last couple of days is all
    > about.
    > Some changes have been made the last couple of days to a few
    > core classes and I would really like us to do a bit more testing in that
    > case.
    > Don't get me wrong, this:
    >
    >
    > http://www.javaforge.com/displayDocu...p?doc_id=30374
    >
    > Is probably the best Kettle release we would ever do, but I
    > would prefer just to make sure.
    >
    > All the best,
    >
    > Matt
    > ____________________________________________
    > Matt Casters, Chief Data Integration
    > Pentaho, Open Source Business Intelligence
    > http://www.pentaho.org <http://www.pentaho.org/> --
    > mcasters (AT) pentaho (DOT) org
    > Tel. +32 (0) 486 97 29 37
    >
    >
    >
    >
    >
    >
    >
    > >

    >




    -------
    Matt Casters
    Chief Data Integration
    Pentaho Open Source Business Intelligence


    --~--~---------~--~----~------------~-------~--~----~
    You received this message because you are subscribed to the Google Groups "kettle-developers" group.
    To post to this group, send email to kettle-developers (AT) googlegroups (DOT) com
    To unsubscribe from this group, send email to kettle-developers-unsubscribe (AT) g...oups (DOT) com
    For more options, visit this group at http://groups.google.com/group/kettle-developers?hl=en
    -~----------~----~----~----~------~----~------~--~---

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.