Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Bug exporting empty XMI

  1. #1
    Join Date
    May 2006
    Posts
    151

    Default Bug exporting empty XMI

    Hi all,

    I'm using metadata editor 0.7.1 on linux. Immediately exporting to XMI after opening the editor silently fails, and hangs up the editor. This is what I can see on the console:

    Code:
    Exception in thread "main" java.lang.NullPointerException
            at java.util.Hashtable.get(Hashtable.java:336)
            at org.pentaho.pms.core.CWM.getInstance(CWM.java:501)
            at org.pentaho.pms.core.CWM.getInstance(CWM.java:495)
            at org.pentaho.pms.editor.MetaEditor.exportToXMI(MetaEditor.java:465)
            at org.pentaho.pms.editor.MetaEditor$8.handleEvent(MetaEditor.java:654)
            at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
            at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1085)
            at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3164)
            at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2840)
            at org.pentaho.pms.editor.MetaEditor.readAndDispatch(MetaEditor.java:560)
            at org.pentaho.pms.editor.MetaEditor.main(MetaEditor.java:3892)
    kind regards,

    Roland Bouman
    http://rpbouman.blogspot.com/
    @rolandbouman on twitter
    Author of "Pentaho Solutions" (Wiley, ISBN: 978-0-470-48432-6)
    Author of "Pentaho Kettle Solutions" (Wiley, ISBN: 978-0-470-63517-9)

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default Fixed

    Thanks Roland, we fixed this in SVN.

    All the best,

    Matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.