Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Mondrian Schema Workbench: No database connection

  1. #1

    Arrow Mondrian Schema Workbench: No database connection


    i can start the Mondiran Schema Workbench, but i can't connect to my Oracle database. The settings for the connection are set:
    - Driver Class Name: oracle.jdbc.driver.OracleDriver
    - Connection URL: jdbcracle:thin:@localhost:1521:dwhdb
    - User & password.

    But when I start a new schema or the JDBC Explorer the following error messages (attached screenshots) appear.
    Do I have to change any configuration file, too?
    I copied the files ojdbc14.jar & into several folders. That wasn't a solution.
    What's the problem?
    THX 4 reply.

    Attached Images Attached Images   

  2. #2
    Join Date
    May 2007


    I had a similar issue with the workbench. It refused to recognize my MSSQL JDBC driver. (I know all the settings were valid, since I could test them in iReport and Cube Designer)
    When I simply registered it as an ODBC and then used the generic sun ODBC driver it worked 'fine'.

    By fine I mean it finally started to recognize that there was a database there, however it refused to recognize any of the structure within the db. It would find users, but no tables.

  3. #3

    Thumbs up

    I solved the problem.
    You have to add the database drivers to the classpath. Edit the file mondrian\demo\ workbench.bat.

    and add the drivers. In this case ojdbc14.jar and

    rem add all needed JDBC drivers to the classpath

    set CP=%CP%;../testlib/mysql-connector-java-3.1.11-bin.jar
    set CP=%CP%;../testlib/postgresql-driver-jdbc3-74-214.jar
    set CP=%CP%;../testlib/ojdbc14.jar
    set CP=%CP%;../testlib/

    and the

    rem you should also put on the calsspath for it to be picked up

    set CP=%CP%;../

    To start the workbench execute the file workbench.bat.



  4. #4


    I am also facing the same problem . I was not able to find the Drivers folder (as according to file and other documentation available which says to place the driver in "drivers" folder) .
    I am fairly new to Pentaho products usage please help me if any of you have the solution of it.
    I also tried the techniques (as setting class path for drivers and file ) but that also not working. Pls help me.

  5. #5
    Join Date
    Mar 2008

    Default create it

    You can simply create the folder, and place your drivers in there.

    There is a line in the startup script that will search this folder for all jar files and add them to the classpath.

  6. #6

    Lightbulb Fix for

    On my system, the script generated the classpath elements like ...:drivers/drivers/foo.jar:...

    I needed to change line 41 from

    and then it worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.