Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: [Mondrian] Mondrian Build Failed

  1. #1
    NoReply-Mondrian-CruiseControl Guest

    Default [Mondrian] Mondrian Build Failed

    View results here -> http://cruisecontrol.hydromatic.net/...20070525121927
    _______________________________________________
    Mondrian mailing list
    Mondrian (AT) pentaho (DOT) org
    http://lists.pentaho.org/mailman/listinfo/mondrian

  2. #2
    Julian Hyde Guest

    Default RE: [Mondrian] Mondrian Build Failed

    There was a communication issue in publishing the latest build log to
    the hydromatic.net <http://hydromatic.net/> server, because of which
    you were seeing stale results.
    With your latest check-in we got green build.

    Good.


    But still an issue concerns me, to get ResultComparatorTest passing we
    have moved DialectTest to run after RolapConnectionTest, with latest
    modifications I tried moving it back to run DialectTest before
    RolapConnectionTest, still it fails. We tried in different Access
    environments.


    The problem was with RolapConnectionTest, which was triggering a bug in
    sun's jdbc-odbc bridge. I knew about the bug, and thought I had a
    workaround, but it turned out that I needed to do more cleanup to
    de-confuse the bridge. Moving DialectTest around meant that
    RolapConnectionTest was not the first test to ask for a JDBC connection,
    and somehow triggered this bug. Fixed in change 9329.

    Julian

    _______________________________________________
    Mondrian mailing list
    Mondrian (AT) pentaho (DOT) org
    http://lists.pentaho.org/mailman/listinfo/mondrian

  3. #3
    Thiyagu Palanisamy Guest

    Default RE: [Mondrian] Mondrian Build Failed

    Julian,

    >>The problem was with RolapConnectionTest, which was triggering a bug in

    sun's jdbc-odbc bridge. I knew about the bug, and thought I had a
    workaround, but it turned out that I needed to do more cleanup to
    de-confuse the bridge. Moving DialectTest around meant that
    RolapConnectionTest was not the first test to ask for a JDBC connection,
    and somehow triggered this bug. Fixed in change 9329.
    Still the same issue exists with our Access environment, I couldn't trace
    down to the root cause. Could you please provide more details about the
    jdbc-odbc bug. I can send you the driver manager logs if you need them.

    To keep the build green, moved Dialect test back to run after
    RolapConnectionTest. Sorry to revert back your test order change.

    - Thiyagu




    "Julian Hyde" <julianhyde (AT) speakeasy (DOT) net>
    Sent by: mondrian-bounces (AT) pentaho (DOT) org
    26/05/2007 00:50
    Please respond to
    Mondrian developer mailing list <mondrian (AT) pentaho (DOT) org>


    To
    "'Thiyagu P'" <thiyagu (AT) gmail (DOT) com>
    cc
    mondrian (AT) pentaho (DOT) org
    Subject
    RE: [Mondrian] Mondrian Build Failed








    There was a communication issue in publishing the latest build log to the
    hydromatic.net server, because of which you were seeing stale results.
    With your latest check-in we got green build.
    Good.

    But still an issue concerns me, to get ResultComparatorTest passing we
    have moved DialectTest to run after RolapConnectionTest, with latest
    modifications I tried moving it back to run DialectTest before
    RolapConnectionTest, still it fails. We tried in different Access
    environments.

    The problem was with RolapConnectionTest, which was triggering a bug in
    sun's jdbc-odbc bridge. I knew about the bug, and thought I had a
    workaround, but it turned out that I needed to do more cleanup to
    de-confuse the bridge. Moving DialectTest around meant that
    RolapConnectionTest was not the first test to ask for a JDBC connection,
    and somehow triggered this bug. Fixed in change 9329.

    Julian_______________________________________________
    Mondrian mailing list
    Mondrian (AT) pentaho (DOT) org
    http://lists.pentaho.org/mailman/listinfo/mondrian


    _______________________________________________
    Mondrian mailing list
    Mondrian (AT) pentaho (DOT) org
    http://lists.pentaho.org/mailman/listinfo/mondrian

  4. #4
    Julian Hyde Guest

    Default RE: [Mondrian] Mondrian Build Failed

    Still the same issue exists with our Access environment, I couldn't
    trace down to the root cause. Could you please provide more details
    about the jdbc-odbc bug. I can send you the driver manager logs if you
    need them.


    I got an automated email from Sun with a bug number, 6504538, and a
    link: http://bugs.sun.com/bugdatabase/view...bug_id=6504538.

    The link doesn't seem to work. But anyway.



    To keep the build green, moved Dialect test back to run after
    RolapConnectionTest. Sorry to revert back your test order change.


    Leave it. It's not that important.

    Julian

    _______________________________________________
    Mondrian mailing list
    Mondrian (AT) pentaho (DOT) org
    http://lists.pentaho.org/mailman/listinfo/mondrian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.