Hitachi Vantara Pentaho Community Forums
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Internet connection

  1. #1

    Default Internet connection

    Hi everyone

    I'm desperatly trying to impeach pentaho from trying to connect the internet.
    After each click, my pentaho solution tries to access the internet and it really bugs me ... indeed, using private data, my boss won't like it ..

    of course i've seen that's it's mostly DTD's, but for example on the login page, it's an uri " uri='http://java.sun.com/jstl/core'" ... what can I put instead ?
    please help me !! thx in advance !

  2. #2
    Join Date
    Nov 2006
    Posts
    135

    Default Need more information please

    Can you tell me more about your application, in particular:

    Are you trying to run disconnected from the Internet?
    Are you connect to a LAN (intranet)?
    Are you building a web application, or a standalone application?

  3. #3

    Default

    I'm building a web application, running on a tomcat server, hosted on a computer connected to the intranet of my company.

    I've got an alert everytime I try to connect to the internet (to get out of the intranet's company), that's why I see everytime Pentaho tries to access the internet. (on distinct every pages, although when the access is refused, it doesn't change anything)

    I would like indeed to run the application only on intranet.

    hope I gave you all the information you need

    P.S : my pentaho version : pentaho_j2ee_deployments-1.5.3.660-0

  4. #4

    Angry

    Quote Originally Posted by joke4028 View Post
    I'm building a web application, running on a tomcat server, hosted on a computer connected to the intranet of my company.

    I've got an alert everytime I try to connect to the internet (to get out of the intranet's company), that's why I see everytime Pentaho tries to access the internet. (on distinct every pages, although when the access is refused, it doesn't change anything)

    I would like indeed to run the application only on intranet.

    hope I gave you all the information you need

    P.S : my pentaho version : pentaho_j2ee_deployments-1.5.3.660-0
    Heloo. this issue is buggin me too. but no one interested with it yet. they says upgrade the wsrp then i found and download it but i cant upgrade it by myself. i still using 1.2.534... and i cannot get the new facilities of tool...

    today i saw 1.5.4 i hope this bug is fixed in it. otherwise i ll search other tool

  5. #5
    Join Date
    Nov 2006
    Posts
    135

    Default Need additional information

    What browser, and what browser version are you using?

    Can you be more specific about what activity you are doing. I don't understand what you are doing when you say "after each click". What are you clicking on?

    Can you be more specific about what the bad behavior is? Is there an error dialog? If so, what exactly does it say? Are you seeing errors in the server log? If so what does it say?

    You say "I got an alert every time I try to connect to the internet". What is the "alert", a dialog box with an error message? If so what does the message say. What do you mean by "connect to the internet"? What is the thing trying to connect to the internet, etc.

  6. #6

    Exclamation

    Quote Originally Posted by sbarkdull View Post
    What browser, and what browser version are you using?

    Can you be more specific about what activity you are doing. I don't understand what you are doing when you say "after each click". What are you clicking on?

    Can you be more specific about what the bad behavior is? Is there an error dialog? If so, what exactly does it say? Are you seeing errors in the server log? If so what does it say?

    You say "I got an alert every time I try to connect to the internet". What is the "alert", a dialog box with an error message? If so what does the message say. What do you mean by "connect to the internet"? What is the thing trying to connect to the internet, etc.
    Hello steve...

    I have searched this answer more than a month. The problem is, pentaho trying to download some files from internet at every run. I have firewall and proxy son it cannot download them... please look at the www.kipas.com.tr/server.log and www.kipas.com.tr/server2ga.log

    you ll see the exceptions. I learned that it is bug from wsrp and jboss. But i dont know how can i upgrade or disable downloading that files.

    Yesterday i have tried 1.5.4 but it is still contains that error. We want it will a completely INTRANET pacgake.

    I have see that more people other than me disturbing at these point but this bug still alive.

    Does this information clear. I can eloborate more if you wish.

  7. #7

    Default

    Quote Originally Posted by sbarkdull View Post
    What browser, and what browser version are you using?

    Can you be more specific about what activity you are doing. I don't understand what you are doing when you say "after each click". What are you clicking on?

    Can you be more specific about what the bad behavior is? Is there an error dialog? If so, what exactly does it say? Are you seeing errors in the server log? If so what does it say?

    You say "I got an alert every time I try to connect to the internet". What is the "alert", a dialog box with an error message? If so what does the message say. What do you mean by "connect to the internet"? What is the thing trying to connect to the internet, etc.
    I've got the similar problem than ikutluay ...

    whatever the browser, whatever the version, pentaho still tries to download things from the internet while loading its pages.
    As I've also a secured internet access, my browser asks me my id and pass everytime I try to access the internet : and while loading the homepage of pentaho, the login page, the navigate page .... (every pages !) this question is still asked !

    as I manage sensitive files, I want my application only intranet ...

    I attach the "alert" popup to be more precise about this ... (sorry, it's in French ... and sorry for my silly english )
    If you still need more information, just ask us !
    Attached Images Attached Images  

  8. #8

    Default

    As we've got no response, I assume taht our problem isn't one that can be answered with a single answer ...

    but point us the files or things pentaho tries to download, or what you think is nedeed locally (and what's not) ..

  9. #9
    Join Date
    Nov 2006
    Posts
    135

    Default

    Quote Originally Posted by ikutluay View Post
    Hello steve...

    I have searched this answer more than a month. The problem is, pentaho trying to download some files from internet at every run. I have firewall and proxy son it cannot download them... please look at the www.kipas.com.tr/server.log and www.kipas.com.tr/server2ga.log

    you ll see the exceptions. I learned that it is bug from wsrp and jboss. But i dont know how can i upgrade or disable downloading that files.

    Yesterday i have tried 1.5.4 but it is still contains that error. We want it will a completely INTRANET pacgake.

    I have see that more people other than me disturbing at these point but this bug still alive.

    Does this information clear. I can eloborate more if you wish.
    I am able to reproduce the exceptions you are seeing in your log file. These exceptions are a result of JBoss portal server's web service component loading a WSDL file, which refers to one or more dtd files. The URI for the dtds is on a remote machine, which obviously you cannot access.

    To resolve this problem, I would suggest taking a look at the Wiki post at JBoss:
    "Using WSRP while being offline or behind a firewall/proxy on JBoss AS 4.0.4.GA"
    http://forums.pentaho.org/showthread.php?t=54502

    Hope this helps.
    Last edited by sbarkdull; 06-25-2007 at 04:52 PM.

  10. #10
    Join Date
    Nov 2006
    Posts
    135

    Default

    Quote Originally Posted by joke4028 View Post
    I've got the similar problem than ikutluay ...

    whatever the browser, whatever the version, pentaho still tries to download things from the internet while loading its pages.
    As I've also a secured internet access, my browser asks me my id and pass everytime I try to access the internet : and while loading the homepage of pentaho, the login page, the navigate page .... (every pages !) this question is still asked !

    as I manage sensitive files, I want my application only intranet ...

    I attach the "alert" popup to be more precise about this ... (sorry, it's in French ... and sorry for my silly english )
    If you still need more information, just ask us !
    The majority of the web pages in the Pentaho Preconfigured Install (PCI) include the file pentaho.js (/pentaho/server/pentaho/res/styles/pentaho-style.war/pentaho.js). The code in pentaho.js tries to load a file at: http://sourceforge.net/sflogo.php. The code looks like this:

    var img = new Image;
    try {
    if( img && document.cookie.indexOf( 'img=no' ) == -1 ) {
    img.src = "http://sourceforge.net/sflogo.php?group_id=140317&type=2";
    setTimeout( 'checkImage()', 10000 );
    }
    } catch (e) { }

    Try changing it to this:

    var img = new Image;
    try {
    if( img && document.cookie.indexOf( 'img=no' ) == -1 ) {
    img.src = "http://sourceforge.net/sflogo.php?group_id=140317&type=2";
    setTimeout( 'checkImage()', 10000 );
    }
    } catch (e) {
    document.cookie += 'img=no'
    }

    If that doesn't fix the problem, just delete the section of code. Let me know if this fixes the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.