Hitachi Vantara Pentaho Community Forums
Results 1 to 8 of 8

Thread: 404 on PropertiesEditor, SubscriptionAdmin and SchedulerAdmin

  1. #1

    Default 404 on PropertiesEditor, SubscriptionAdmin and SchedulerAdmin

    Hello, I've just installed Pentaho BI 1.5.4 on a tomcat 5.0 (http://forums.pentaho.org/showthread.php?t=54706 for preceding episodes), and the platform seems to work (I mean, xaction's are agree to run...)
    But now in the demo interface, when I want to reach one of the admin panel in the title of this topic (PropertiesEditor, SubscriptionAdmin, SchedulerAdmin), I just get a 404 error with the message "The requested resource is unavailable".

    Do you know why, and how could I fix this ?

  2. #2
    Join Date
    Jun 2006
    Posts
    102

    Default

    Hi Fabien,

    Glade to see that you solved your first problem can you tell more on what was the problem? and for your issue here can you provide some logs see the server.log it should be in
    $CATALINA_HOME/bin or in $CATALINA_HOME/logs/

    Good Luck
    Yassine

  3. #3

    Default

    I don't really know from where my old problem came from (probably from some bad xml fragment), but I have posted my solution in the dedicated thread.


    For my 404 issue, the server log don't even log the access, whereas I can see it in the localhost_access log file :
    Code:
    [25/Jun/2007:10:13:37 +0100] 127.0.0.1 "GET /Pentaho/Admin HTTP/1.1" 200 18947 343 "http://localhost/Pentaho/Admin" "Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4"
    [25/Jun/2007:10:13:40 +0100] 127.0.0.1 "GET /pentaho/SubscriptionAdmin HTTP/1.1" 404 1016 0 "http://localhost/Pentaho/Admin" "Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4"
    Last edited by fabien.meurillon; 06-25-2007 at 04:18 AM.

  4. #4
    Join Date
    Jun 2006
    Posts
    102

    Default

    Bonjour fabien,

    i dont know if you already solved this but if not i would suggest first checking if the GET SubscriptionAdmin_jsp.class exists and if it does not, shutdown tomcat, increase the log level of log4j in log4j.xml in WEB-INF/classes
    start it again and you may get enough information than.
    i assume this is an own build you are messing with right? if yes did you compiled the jsp files? you can check this by trying to access pentaho/Home URI or looking in classes if you have the org.apache.... classes for your jsps

    good luck
    Yassine

  5. #5

    Default

    Compiled JSPs are there. Could it be a problem with the servlet declarations of those precompiled JSPs in the web.xml ?
    I've raised the log4j debug level to "DEBUG", but the 404 error stay quiet in the server.log. (I think it's logical : if tomcat raise a 404 error, the platform don't receive the request and don't log anything)

    I hope my textual english doesn't sound too french
    Thank you for your help Yassine.

    Edit : OK, it's my fault. The link in the platform had /pentaho/SubscriptionAdmin as destination, whereas the real context is /Pentaho.
    I'm going to search where this link is defined and fix it.
    Edit 2 : Hum, the context is hard-coded in the *.url files of pentaho-solutions. Weird thing, to my mind, even for a demo app.
    Last edited by fabien.meurillon; 06-25-2007 at 09:51 AM.

  6. #6

    Default

    Ok, things are working better now.
    But in the PropertiesPanel I can't change the ACLs, whereas it was possible when I tried the PCI.

    I join a capture of the screen that I get. Did I miss something in my manual deployment to tomcat 5 ?
    Attached Images Attached Images  
    Fabien

  7. #7

    Default

    Up !
    Nobody knows ?
    Fabien

  8. #8
    Join Date
    Oct 2006
    Posts
    817

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.