Hitachi Vantara Pentaho Community Forums
Results 1 to 1 of 1

Thread: javax.servlet.ServletException

  1. #1

    Exclamation javax.servlet.ServletException

    Hello everyone,

    I have been attempting to manually deploy Pentaho 1.5.4 on JBoss Portal Bundled 2.4.1. I have used the latest Manual Deployment guide and have followed all the steps. I've been able to get JBoss to start up properly and access the login page for Pentaho. However when I attempt to login an error gets displayed:


    type Exception report
    message
    description The server encountered an internal error () that prevented it from fulfilling this request.
    exception
    javax.servlet.ServletException: Filter execution threw an exception
    org.pentaho.core.system.SystemStatusFilter.doFilter(SystemStatusFilter.java:53)
    org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
    root cause
    java.lang.NoClassDefFoundError
    org.pentaho.repository.runtime.RuntimeRepository.setSession(RuntimeRepository.java:75)
    org.pentaho.core.system.PentahoSystem.getRuntimeRepository(PentahoSystem.java:1140)
    org.pentaho.core.solution.SolutionEngineBase.execute(SolutionEngineBase.java:198)
    org.pentaho.core.solution.SolutionEngineBase.execute(SolutionEngineBase.java:164)
    org.pentaho.core.solution.SolutionEngine.execute(SolutionEngine.java:58)
    org.pentaho.core.system.PentahoSystem.sessionStartup(PentahoSystem.java:843)
    com.pentaho.security.SecurityStartupFilter.doFilter(SecurityStartupFilter.java:65)
    org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
    org.acegisecurity.providers.anonymous.AnonymousProcessingFilter.doFilter(AnonymousProcessingFilter.java:125)
    org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
    org.acegisecurity.ui.rememberme.RememberMeProcessingFilter.doFilter(RememberMeProcessingFilter.java:142)
    org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
    com.pentaho.security.RequestParameterAuthenticationFilter.doFilter(RequestParameterAuthenticationFilter.java:160)
    org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
    org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:178)
    org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
    org.acegisecurity.ui.AbstractProcessingFilter.doFilter(AbstractProcessingFilter.java:217)
    org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
    org.acegisecurity.ui.logout.LogoutFilter.doFilter(LogoutFilter.java:108)
    org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
    com.pentaho.security.HttpSessionReuseDetectionFilter.doFilter(HttpSessionReuseDetectionFilter.java:142)
    org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
    org.acegisecurity.context.HttpSessionContextIntegrationFilter.doFilter(HttpSessionContextIntegrationFilter.java:193)
    org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
    org.acegisecurity.wrapper.SecurityContextHolderAwareRequestFilter.doFilter(SecurityContextHolderAwareRequestFilter.java:81)
    org.acegisecurity.util.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:274)
    org.acegisecurity.util.FilterChainProxy.doFilter(FilterChainProxy.java:148)
    org.acegisecurity.util.FilterToBeanProxy.doFilter(FilterToBeanProxy.java:98)
    org.pentaho.core.system.SystemStatusFilter.doFilter(SystemStatusFilter.java:53)
    org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
    I've been able to tackle all of the other bugs that have come my way, but this one is proving rather troublesome. Any ideas why this problem would come up?

    I used the Pentaho-solutions, data, and J2EE deployments for the 1.5.4 release. My server is running Slackware 11.0 with a Pentium III processor.

    I've attached my server log. Any assistance would be greatly appreciated!
    Attached Files Attached Files
    The best thing about a boolean is even if you are wrong, you are only off by a bit.
    Anonymous

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.