Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Support for subselect queries

  1. #1
    Join Date
    Jun 2007
    Posts
    3

    Default Support for subselect queries

    hi everyone,

    i'm new with pentaho and i still don't know if it's possible to have subselect and other complex queries?

    thanks.

  2. #2
    Join Date
    Mar 2006
    Posts
    683

    Default

    rbaluyos,

    I know of a way to do subselects and complex queries. So it is possible. It's not the easiest thing to do though atleast in jfree 0.8.8.
    I do believe they have added features in 0.9 that should allow for such actions a how lot easier.
    You'll have to do some more digging to find out the new feature list of jfree 0.9.
    I do know that other people were using other reporting tools such as birt and jasper to do it when they are needed.
    I have been a bit out of the loop so this is what I recall.

    Hope that helps,

    Nic
    Try not to have too much fun.
    - - - -
    Nic Guzaldo
    That guy who shows up here
    and there

  3. #3
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    There's a difference between sub-selects and sub-reports.

    The classic-engine has some primitive support for master-detail reports now - these subreports are printed below the band to which they have been attached. However, these beasts are still strictly banded and so it is not possible to have two subreports side on side on each other. But at least the things similar to the old and feared "Multi-report" demo are now supported natively.

    The support for subreports had been added with JFreeReport 0.8.8, but the thing is totally buggy there. You better use the latest Pentaho-Reporting-Classic version 0.8.9 for a more stable experience. (Version 0.8.9-pre2 with even more bugfixes will be released tomorrow.)

    Have fun,
    said Thomas
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  4. #4
    Join Date
    Jun 2007
    Posts
    3

    Default

    thanks guzaldon and taqua,

    i'm using the latest postgresql. i'll figure it out. will post for any progress.

    glad to know there are still active members here in the forum. i thought the forum has been inactive.

    thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.