Hitachi Vantara Pentaho Community Forums
Results 1 to 8 of 8

Thread: Birt + Pentaho

  1. #1

    Default Birt + Pentaho

    Bonjour,
    c'est encore moi.
    Voilà, maintenant, je suis passé sur BIRT. Bel outil, vraiment complet.
    Par contre, je bute encore sur l'intégration d'un rapport BIRT sur Pentaho.
    J'ai bien créé mon action comme il faut, mais quand je la teste elle ne fonctionne pas, me disant que mon rapport contient des erreurs... chose qui n'est pas vrai puisque le preview du rapport fonctionne.
    Je pense qu'il s'agit d'un problème de connexion aux base de données. Ai-je raison?
    Ou sinon, avez vous une solution?
    Merci.

  2. #2

    Default

    Laurent,

    Pentaho utilise encore une vieille version de BIRT (je crois que c'est 1.2.x).
    Fort probablement tu as des erreurs parce que ton report est créé avec BIRT 2.x, que Pentaho ne comprend pas.

    Sauver le report comme BIRT 1.2 pourrait resoudre ton probleme.

    Cordiallement,

    Bart

  3. #3

    Default

    Euh, moi je veux bien, mais on fait comment pour sauvegarder le rapport comme BIRT 1.2???
    C'est surement une question con mais bon là franchement je vois pas.

  4. #4

    Default

    Bonjour,

    Je ne pense pas que ce soit sa, j'ai reussi il y a un mois a integré des rapports avec BIRT 2.1 sur le portail Pentaho.
    J'ai aussi pas mal galeré. Il faut utiliser Pentaho Design Studio avec le tuto qui va bien

    Tu peux trouver tout ça dans l'espace de telechargement

    Bonne continuation,

    Guillaume

  5. #5

    Default

    J'utilise déjà Design Studio et c'est d'ailleurs avec lui que j'ai créé l'action qui va normalement bien.
    Ce que j'ai du mal à comprendre c'est pourquoi la preview sur Design Studio marche et puis que sur Pentaho cela ne marche pas.
    T'avais pas eu un problème de driver de connexion?
    Je pense que mon problème vient de là.

  6. #6

    Default

    Je n'ai jamais reussi a faire fonctionner l'apercu dans Design Studio. Ma preview fonctionnait sur BIRT. J'ai configurer un peu aléatoirement mon xaction sous Design Studio. Et ca a fonctionné
    Pour les drivers de connexion, j'utilise les mysqlconnectorXX (jme souviens plus trop, j'ai changé de projet). Il faut les mettre dans un répertoire de Pentaho mais je ne me souviens plus lequel.

    Petite précision, j'ai fait sa avec la version 1.2 de Pentaho. Je n'ai jamais reussi a le faire avec la 1.5

  7. #7

    Default

    Ah c'est peut être pour ça, la 1.5 a peut être (je dis bien peut être) un problème la dessus.
    Les drivers se mettent dans le répertoire lib de ton application web.
    La preview BIRT ET la preview Design Studio fonctionne mais pas sur Pentaho, c'est rageant.
    Je vais continuer à chercher donc.
    Merci quand même.

  8. #8

    Default

    Ok, c'est effectivement un problème de version du fichier.
    J'ai retouché le XML du fichier et mis la version à 1, et là niquel ça tourne.
    Par contre, est ce que vous pourriez me dire comment faire pour automatiser ceci, parce que aller toucher le XML généré par BIRT c'est pas vraiment le but de notre transition vers Pentaho...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.