Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Jndi Driver missing

  1. #1
    Join Date
    Jul 2007

    Default Jndi Driver missing

    I downloaded the cube designer source code from the SVN.

    I run the product . When I am trying to add a new JNDI connection, I can only find the sun.jdbc.odbc.JdbcOdbcDriver at the Driver combo..

    Eclipse 3.2, Jre 1.5.

    Could anyone tell me why is so ?
    Tks .

  2. #2


    The list should be dynamically built based on which JDBC drivers you have in your .\CubeDesigner\lib\jdbc directory. If you download our 0.7.2 distribution, several drivers are included by default. Otherwise, drop the driver of your choosing in this directory, restart the cube designer and your driver should appear in the drop down list.


  3. #3
    Join Date
    Oct 2007


    Im having the same problem as the op, the only driver i see is jdbcodbc and when I place my postgres driver in cubedesigner\lib\jdbc it does not show up on the list.
    Last edited by Prometheas; 10-01-2007 at 05:44 PM.

  4. #4
    Join Date
    Sep 2007

    Default Change current directory

    This problem is solved by starting the Cube Designer from the directory where it is installed (i.e. with ./CubeDesigner).

    I found that, generally, when creating a link to a Pentaho application, it's better to create a small script that does a cd to where the application is installed and then launches the app.

  5. #5
    Join Date
    Jul 2008

    Default CubeDesigner not find the postgres jdbc drive

    I have the same problem.
    I think it should be a CubeDesigner bug.
    Can anybody help me?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.