Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: Put a file with SFTP

  1. #1

    Question Put a file with SFTP

    Hi,

    I'm trying to send a file over SFTP, but when I try to run my job I get the following error:

    2007/07/18 20:09:16 - Put a file with SFTP 1 - Start of SFTP job entry
    2007/07/18 20:09:16 - Put a file with SFTP 1 - Opened SFTP connection to server [spdevdb10] on port [22] with username [oracle]
    2007/07/18 20:09:17 - Put a file with SFTP 1 - Changed to directory [/home/oracle/pentaho]
    2007/07/18 20:09:17 - Put a file with SFTP 1 - ERROR (version 2.5.0, build 25002 from 2007/05/04 00:20:04) : Error getting files from SCP : null
    2007/07/18 20:09:17 - Put a file with SFTP 1 - ERROR (version 2.5.0, build 25002 from 2007/05/04 00:20:04) : java.lang.NullPointerException

    Am I missing something?

    Regards,
    Fernando Cesar.


  2. #2

    Default

    Hello everybody!

    Any clue will be very very helpfull.

    Thanks.

    Fernando Cesar.

  3. #3

    Default

    C'mon guys, nobody never did it?

    Regards,
    Fernando Cesar.

  4. #4
    Join Date
    May 2006
    Posts
    4,882

    Default

    Probably not... it's a pretty new step, and not everyone uses every step. I can try to sftp, but not now.

    Regards,
    Sven

  5. #5

    Default

    Thanks Sven, I will do another tests. But if you can try later, I will be very thankful.

    Regards,
    Fernando

  6. #6
    Join Date
    May 2006
    Posts
    4,882

    Default

    It works for me.

    Regards,
    Sven

  7. #7

    Default

    Hummmm....
    I still with the same error....
    Sven, can you send me the .kjb from your test?

    Thank you,
    Fernando.

  8. #8
    Join Date
    May 2006
    Posts
    4,882

    Default

    Is a picture of my settings ok? I also tried wildcards in the wildcard field and they also work for me.

    But I do think you have to fill in all fields.

    Regards,
    Sven
    Attached Images Attached Images  

  9. #9
    Join Date
    Sep 2007
    Posts
    9

    Default Hi SAME PROBLEM

    I Have a similar issue. Works with port 22 to ftp server but with port 21 it throws the error.

    Are you using port 21

    I believe port 21 is not secure where as port 22 is secure.

    Try using port 22 - note your server should allow port 22 (Secure FTP)

    Hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.