Hitachi Vantara Pentaho Community Forums
Results 1 to 7 of 7

Thread: Turn off system beep

  1. #1
    Join Date
    Jun 2007
    Posts
    112

    Default Turn off system beep

    I'm Pentaho Data Integration 2.5 on Windows XP and I'd like to be able to turn off the system beep. I have put sound on mute with the Windows control panel. but it doesn't stop the beep. In MySQL, you can use -b when you start up to turn off the beep. Is there something similar for Pentaho?

    Sorry, this may be a newbie question, but the beeping when I delete a step is annoying the person in the next cube.

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    LOL... never noticed it... is your sound totally off?

    Raise a CRQ ... I would propose to just remove the sound (I don't think it was intentional anyway to beep)

    Regards,
    Sven

  3. #3
    Join Date
    May 2006
    Posts
    4,882

    Default

    ROTFL.... make your neighbour happy :

    - Start/Control Panel/Sounds and Audio
    - Sounds Tab
    - Find the sound "Exclamation" and put it to none.

    Your beeping problem is solved... even system wide

    Regards,
    Sven

    P.S. The beep is not in Spoon, but in SWT. The moment a warning dialog box is shown you get a beep (it's not configurable for warnings).

  4. #4
    Join Date
    Jun 2007
    Posts
    112

    Default

    Thanks for the quick responses! I've muted the sound, set the sound scheme to No Sounds in the control panel (which also sets Exclamation to None) and even tried disabling the Windows Audio service, yet the beep persists.

    Perhaps my coworker will have to get used to an occasional beep. It injects a bit of excitement.

  5. #5
    Join Date
    May 2006
    Posts
    4,882

    Default

    Strange... try explicitly setting Exclamation Sound to None... it works for me.

    As a test, change the exclamation sound e.g. to "tada" and completely drive your neighbour bonkers

    Regards,
    Sven

  6. #6
    Join Date
    Apr 2007
    Posts
    16

    Default

    Tell your neighbor, "it's the sound of work getting done, you should try it sometime." ;-)

  7. #7
    Join Date
    Jun 2007
    Posts
    112

    Default Quiet returns

    Peace reigns again in the office! Here's my beep saga...

    I started the day yesterday by setting up MySQL on my Windows laptop. I'd been using it on a Linux box, but this was my first time using it with Windows. When MySQL gave me an error, it was accompanied by a rather startling beep. After a few of those errors, a coworker and I tried increasingly drastic measures to get the beep to stop, including finally disabling the Windows Audio service. As a last resort, I turned to the MySQL docs and found that if I set the -b option on login, the error messages no longer came with the beep.

    Things were quiet for a while, but later in the day I started doing some work in Spoon. Every alert message was accompanied by the same loud beep I had been getting that morning from MySQL. After more fumbling around, I finally turned the Windows Audio service back on. This allowed the Spoon alert to use the regular sound card, which responded normally when I put it on mute.

    Thanks for your tips everybody!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.