Hitachi Vantara Pentaho Community Forums
Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: jboss 4.0.5.ga notes w/ 1.6 RC1

  1. #1

    Default jboss 4.0.5.ga notes w/ 1.6 RC1

    Just one note thus far, and to be precise related to EAR deployments -

    The infamous "java.lang.NoSuchMethodError: org.apache.commons.httpclient.HttpConnectionManager.getParams()" has raised its ugly head again.

    Updating from 3.0-rc4 to 3.1-rc1 commons-httpclient did not make a difference (shouldn't have anyway). Since I was attempting an EAR deploy, also placed the jar within the /WEB-INF/lib, no difference.

    Root of $JBOSS_HOME/lib/commons-httpclient.jar updated, no difference.

    *$JBOSS_HOME/server/<default?>/lib/commons-httpclient.jar updated -- this was the ticket, updating this to one of the 3.x series.

    I see some class-loader configs in jboss-web.xml, would one of these correct this behavior? And if it can, could it be turned on by default?
    Last edited by dhartford; 08-21-2007 at 08:45 AM.

  2. #2

    Default

    Enabling the classLoading repository following http://wiki.jboss.org/wiki/Wiki.jsp?...gConfiguration . The reason the setup classLoading was to

    1) See if it would fix a NoClassDefFound: org.pentaho.repository.HibernateUtil after successful login.

    2) Check commons-httpclient back to 2.x series on the default 4.0.5.GA server, but have the recent (3.x series) within the app. Using Java2DelegateParent=false should allow this.

    example:
    jboss-app.xml
    ==========
    <!-- setup classLoader repository. java2ParentDelegation to always have package libs override server libs for this application -->
    <loader-repository>
    dot.com:loader=pentaho
    <loader-repository-config>
    java2ParentDelegation=false
    </loader-repository-config>
    </loader-repository>
    ==========
    jboss-web.xml
    ==========
    <class-loading java2ClassLoadingCompliance="false">
    <loader-repository>
    dot.com:loader=pentaho
    <loader-repository-config>java2ParentDelegation=false</loader-repository-config>
    </loader-repository>
    </class-loading>
    ==========


    After configuring jboss-app.xml and jboss-web.xml, ran into the linkage problem mentioned here: http://forums.pentaho.org/showthread.php?t=56039

    Removing jtidy.jar corrected the linkage problem.

    However, still having HibernateUtil problem after initial login.

    Edit: HibernateUtil problem same as here - http://forums.pentaho.org/showthread.php?t=54939&page=2

    Other errors when dom4j missing from classpath/HibernateUtil problems:

    dom4j/HibernateUtil also experiences this problem when dom4j is not in classpath during startup
    =======================
    11:04:02,583 ERROR [HibernateUtil] HIBUTIL.ERROR_0006 - Building SessionFactory failed.
    org.hibernate.HibernateException: Could not instantiate cache implementation
    .....
    11:04:03,005 FATAL [Logger] misc-org.pentaho.core.system.PentahoSystem: PentahoSystem.ERROR_0013 - Could not create obje
    ct com.pentaho.repository.subscribe.SubscriptionRepository
    java.lang.ExceptionInInitializerError
    =======================
    Last edited by dhartford; 08-22-2007 at 11:29 AM.

  3. #3

    Default dom4j

    Stuck --

    The org.pentaho.repository.HibernateUtil NoClassDefFound problem seems related to dom4j.

    However, by adding dom4j to the classpath, the template engine stops working (although HibernateUtil now works fine).

    What to do or test, I'm out of ideas...

  4. #4

    Default

    Template engine errors


    webpage:
    ==============
    Template engine could not be loaded
    ==============

    server log:
    ==============
    2007-08-22 09:46:14,044 ERROR [org.pentaho.util.logging.Logger] misc-org.pentaho.core.system.PentahoSystem: PentahoSystem.ERROR_0023 - Could not return object IUITemplater of scope null
    ==============

    I want to reiterate - when I did not have dom4j-1.6.1 in the classpath, the template engine was working fine, but HibernateUtil was not. With dom4j-1.6.1 now in the classpath, the template engine now no longer works (But HibernateUtil does).
    Last edited by dhartford; 08-22-2007 at 10:01 AM.

  5. #5

    Default

    ....and running into similar problems with WAR deployments. Default install with no modifications, then with some fixes, still can not test Pentaho 1.6 as simply can not get it installed.

    Does Pentaho 1.6 just plain not work on jboss 4.0.5.GA?

  6. #6
    Join Date
    Apr 2007
    Posts
    2,010

    Default

    There seems to be quite a few jboss issues.

    One of note is the plan to upgrade to 4.2 for the PCI in 1.6 RC2:

    http://jira.pentaho.org/browse/BISERVER-222

    Other posts elsewhere seem to imply that work is complete, never-the-less it's a blocker for RC2 anyway.

    Maybe the fixes for Jboss 4.2 will also fix these problems with 4.0.5?

    ( if you search for jboss at jira.pentaho.org and order by the date (newest first ) you'll see the various issues i'm talking about..

  7. #7
    Join Date
    Oct 2006
    Posts
    817

    Default

    The PCI has been upgraded. The bug has not been closed since not all of the paths through the build scripts have been tested.

  8. #8

    Default

    I tested build 807, created a J2EE_Deployment zip, then tried to create a jboss-non-portal-ear - with the same results related to HibernateUtil exception problems on jboss 4.0.5.ga.

  9. #9
    Join Date
    Oct 2006
    Posts
    817

    Default

    Who has not resolved their deployment issues? I'd like to get the the bottom of the problems mentioned in this thread and this one. Please list the following information:

    • Java version.
    • If not using PCI, what app server are you using? If JBoss, are you using JBoss Portal too?
    • Name of Pentaho file downloaded including build number (e.g. 1.6.0-RC2.808).
    • What database you're using.
    • Any modifications to original download including Ant properties files, files under pentaho-solutions, etc.
    • Name(s) of Ant target(s) run.
    • Complete server.log from startup to shutdown.


    I've tested the EAR built with Ant target "ear-pentaho-jboss-hsqldb-no-portal" from nightly j2ee deployments v1.6.0-RC2.808 on JBoss 4.2.1 and it seems to work.

  10. #10

    Default

    • Java version 1.6.0-b105
    • Jboss 4.0.5.GA, no portal, no library modifications.
    • pentaho_j2ee_deployments-1.6.0-RC2.813
    • MySQL 4
    • web.xml: enabled hibernateManaged=true.
    • web.xml: Acegi security stuff.
    • web.xml: base-url of the server.
    • application.xml: added dao-ldap-authorities-populator.jar.
    • application.xml: removed legacy/older lib references related to pentaho-*.jar, so just use pentaho-*-RC2.jar.
    • application.xml: removed datasource references, managed from jboss *-ds.xml files in a seperate SAR (this has worked fine, no challenges related to this).
    • Name(s) of Ant target(s) run -- "build-all" (use jboss-mysql-no-portal ear)
    • Complete server.log from startup to shutdown -- clipped datasource/acegi security. Debug on.
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.