Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Missing transformations from exported XML

  1. #1
    Join Date
    Aug 2007
    Posts
    4

    Question Missing transformations from exported XML

    I just inherited a Kettle ETL system at a new job, and my predecessor's exported XML includes a large <transformations> block. I have imported his XML, made changes, saved, then exported, and the resulting file is completely missing the <transformations> block. Am I missing a setting somewhere that's eliminating this?

    I'm very impressed with the product - thanks for making my job easier!

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    Your predecessor maybe exported a whole repository? Then you also have to import all again via the repository explorer.

    Regards,
    Sven

  3. #3
    Join Date
    Aug 2007
    Posts
    4

    Default

    I think I have imported the entire repository. When I Explore Repository, I can see many Transformations (although their names are in blue text instead of black), and they're in my ETL process when I look through it. How can I export the entire repository instead of just the jobs or whatever I'm getting now?

  4. #4
    Join Date
    May 2006
    Posts
    4,882

    Default

    Export and import via repository explorer... for export: Repository ... explore repository, right click on the root of the repository and select one of the export options (all/jobs/transformations).

    Regards,
    Sven

  5. #5
    Join Date
    Aug 2007
    Posts
    4

    Thumbs up

    Thank you - it worked!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.