Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Running Under Xcode/Eclipse

  1. #1
    Join Date
    Sep 2007
    Posts
    10

    Default Running Under Xcode/Eclipse

    In an attempt to create an 'ETLRunner' class that will execute a predefined .ktr file, I've had little success running under Mac OSX Xcode IDE.
    Has anyone been successful at this? We use Xcode for other java work and I'm wondering if we have to go to Eclipse to get it working at all.

    If so what version, setting, special configuration would be needed?

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    Don't have a Mac, but do you get Spoon running under Xcode. If you do you have a good hunch the problem is in your own code.

    Regards,
    Sven

  3. #3
    Join Date
    Sep 2007
    Posts
    10

    Default

    No I'm running Spoon by itself. I was trying to create an ETLRunner class and I'm not sure which compile options I should be using. I get the situation in the debugger where things go crazy when I step through my code which is a simple xform runner.

    Must I use Eclipse?

  4. #4
    Join Date
    May 2006
    Posts
    4,882

    Default

    Nothing in Kettle/PDI is directly linked with Eclipse... the only thing in common is probably SWT but this comes from the kettle libswt directory. There's nothing special we set in Eclipse as options (you do need JDK 1.5 for v3).

    So what the previous suggestion was, was actually to compile and run spoon via Xcode, and let us know whether that works.

    For the rest, what kind of errors do you get?

    Regards,
    Sven

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.