Hitachi Vantara Pentaho Community Forums
Results 1 to 13 of 13

Thread: Kettle on 64-bit linux

  1. #1
    Join Date
    Jun 2007
    Posts
    128

    Default Kettle on 64-bit linux

    Hi,

    I am trying to use kettle 2.5.1 on linux 64-bit machine with jdk-1.5.0_12 and eclipse-SDK-3.2.2-linux-gtk.
    When I run the spoon script i am getting java.lang.UnsatisfiedLinkError:no swt-gtk-333: error.
    can anybody suggest me what should be done to solve this problem.
    Do we need to use any other version of eclipse?


    Thanks
    Sreelatha

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    Have a look in the spoon.sh script and see which SWT version it would use in your case. Maybe it's a bug in the script, or maybe you use an exotic linux version which isn't recognized properly.

    Regards,
    Sven

  3. #3
    Join Date
    Jun 2007
    Posts
    128

    Default

    Hi,

    The same swt and spoon.sh script are working without any problem on 32-bit linux machine.
    But there is a problem on 64-bit machine.

    Thanks
    Sreelatha

  4. #4
    Join Date
    May 2006
    Posts
    4,882

    Default

    yes, since for 64 bit it should take another library... so probably the script doesn't recognize the 64 bit properly... have a look at the libswt directory and at the script and see how you can link them together.

    What does "uname -s" give you as output and "uname -m"?

    Regards,
    Sven

  5. #5
    Join Date
    Jun 2007
    Posts
    128

    Default

    Hi,

    uname -m is giving Linux and uname -s x86_64.x86_64 is is there in libswt.
    What might be the problem?

    Thanks
    Sreelatha

  6. #6
    Join Date
    May 2006
    Posts
    4,882

    Default

    -s will probably give Linux... ... no idea for now...

    Can you activate debugging in the script and see whether LIBPATH is set correctly.

    And do you have a "/usr/lib/xulrunner-1.8.1/" directory?

    Regards,
    Sven
    Last edited by sboden; 09-07-2007 at 03:32 AM.

  7. #7
    Join Date
    Jun 2007
    Posts
    128

    Default

    Hi,
    Soory in the above post i have given wrongly uname -s is giving linux and uname -m x86_64.
    Is it compulsory to have /usr/lib/xulrunner-1.8.1.
    Actually on my 32.bit machine I was running without problem even though there is no /usr/lib/xulrunner-1.8.1.

    Thanks
    Sreelatha

  8. #8
    Join Date
    May 2006
    Posts
    4,882

    Default

    Don't know whether xulrunner is required... I don't see much more that could go wrong in the script.

    Regards,
    Sven

  9. #9
    Join Date
    Jun 2007
    Posts
    128

    Default

    Hi,

    pan,kitchen and carte are working fine.But The problem is only with kettle.

    Thanks
    Sreelatha

  10. #10
    Join Date
    May 2006
    Posts
    4,882

    Default

    Short term I see no solution but to run spoon on another system.
    Maybe someone else has experience running spoon on a 64 bit linux system.

    Regards,
    Sven

  11. #11
    Join Date
    Jun 2007
    Posts
    128

    Default

    Hi,
    Thanks for your suggestions and sorry for troubling you.
    My problem is solved.The error was because of jre.I have installed 64 bit jre and error disappeared.

    Thanks
    Sreelatha

  12. #12
    Join Date
    Nov 1999
    Posts
    9,729

    Default Soluation

    Sreelatha was running a 32-bit Java runtime environment.
    You need a 64-bit version for PDI/Eclipse/SWT to run correctly on Linux 64-bit.

  13. #13

    Default how did you solved your problem?

    I am using linux 64 machine, have java 1.7 and facing the similar error, so can you tell me how to solve this error?


    Quote Originally Posted by Sreelatha View Post
    Hi,

    I am trying to use kettle 2.5.1 on linux 64-bit machine with jdk-1.5.0_12 and eclipse-SDK-3.2.2-linux-gtk.
    When I run the spoon script i am getting java.lang.UnsatisfiedLinkError:no swt-gtk-333: error.
    can anybody suggest me what should be done to solve this problem.
    Do we need to use any other version of eclipse?


    Thanks
    Sreelatha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.