Hitachi Vantara Pentaho Community Forums
Results 1 to 10 of 10

Thread: Problem while sending message: javax.mail.MessagingException

  1. #1
    Join Date
    Sep 2007
    Posts
    7

    Question Problem while sending message: javax.mail.MessagingException

    Problem while sending message: javax.mail.MessagingException:

    hi.. i'm a newbie in Kettle.. I want to e-mail 2 xls file to a certain e-mail address through a Job.. but I always encounter the following error message...

    Problem while sending message: javax.mail.MessagingException: Exception reading response;
    nested exception is:
    javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?

    I have this following settings:
    servername: smtp.gmail.com
    port: 587
    secure connection : TLS


    can you give me a solution to this problem.. or a working example will do. thanks in advance..
    mhiL

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    Which version of PDI are you using?

    This one e.g. is solved in 2.5.1: http://jira.pentaho.org/browse/PDI-64

    Regards,
    Sven

  3. #3

    Default

    Hi mhil, Sven,

    Mail job entry do not support yet TLS authentification (but it do support SSL) :-)
    It's not hard to correct that.

    i posted a CRQ : http://jira.pentaho.org/browse/PDI-149

    Rgds

    Samatar

  4. #4

    Smile Secure connection

    Hi,

    Gmail uses 25, 465 and 587 for SMTP, but since almost all isps block 25, 465
    is the preferred SMTP with SSL for gmail, and 587 is the preferred SMTP with
    TLS port.

    Rgds

    Samatar

  5. #5
    Join Date
    Sep 2007
    Posts
    7

    Default

    hi shassan2! thanks for the quick reply..
    as i said I'm a newbie in doing Kettle jobs.. I'm sorry but I don't know where to put this line..

    props.put("mail.smtp.starttls.enable","true");

    can you please make a detailed instruction on how to make the "Mail" entry work.. thanks!


    regards,
    mhiL

  6. #6
    Join Date
    Sep 2007
    Posts
    7

    Default

    hi sboden!

    thanks for the reply.. but my problem is not after sending the e-mail but on the process of sending the e-mail... but thank you for a future reference you've shared with me..

    mhiL

  7. #7

    Default

    mhiL,
    The CRQ http://jira.pentaho.org/browse/PDI-64
    was implemented in both 2.5.2 (next release) and 3.0.

    Which version do you use today?

    Rgds

  8. #8
    Join Date
    Sep 2007
    Posts
    7

    Default

    i'm using 2.5.0...
    thank you for the reply..

    mhiL

  9. #9

    Default

    You have to wait until 2.5.2 release.
    But if you want to test the feature, you can get the 2.5.2 (Do not use it in PROD).

    Rgds

    Samatar

  10. #10
    Join Date
    Jan 2013
    Posts
    1

    Default

    mhiL have that's problem, solved change servername: smtp.gmail.com port: 25 secure connection : TLS. Bye!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.