Hitachi Vantara Pentaho Community Forums
Results 1 to 8 of 8

Thread: Error: JFreeReport.ERROR_0007

  1. #1
    Join Date
    Sep 2007
    Posts
    7

    Default Error: JFreeReport.ERROR_0007

    Error:JFreeReport.ERROR_0007 - Could not parse report samples\getting-started\Testing.xml - java.lang.NullPointerException (org.pentaho.plugin.jfreereport.components.JFreeReportLoadComponent)

    does anybody know what does this error means..

    please help me...

    mhiL

  2. #2
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    This cryptic error means that your report definition cannot be parsed. Chances are high that it is not a valid report definition file. But with any additional information, we barely can tell you more about it.

    Have fun,
    said Thomas
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  3. #3
    Join Date
    Sep 2007
    Posts
    7

    Default

    i'm a newbie in JFreeReport.. I just did what this site tells me..
    --http://www.nicholasgoodman.com/bt/blog/category/pentaho/how-to/

    .. following the 8 steps and I encounter the following error:

    Error:JFreeReport.ERROR_0007 - Could not parse report samples\getting-started\Testing.xml - java.lang.NullPointerException (org.pentaho.plugin.jfreereport.components.JFreeRe portLoadComponent)

    thank you for the reply Thomas!

    mhiL

  4. #4
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    Well, *what* did you do. The first entry there has 8 steps, but it does not tell me how you created the report and on what version of the platform/report designer you are working.

    Please tell us: What version of the design tools did you use in conjunction with what version of the platform. (And if version of platform < version of designtools, then well, upgrade to the platform that matches your design tools. (The last time I tried to open a Office-200x file in my jolly old DOS-Word5 it didnt work either. Oh, yes, I complained at Microsoft, but somehow they didnt thought I was serious on that matter. Unbelievable, isn't it? )

    Have fun,
    said Thomas
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

  5. #5
    Join Date
    Sep 2007
    Posts
    7

    Default

    PentahoReportDesigner-1.6.0.308-RC1
    KEttle-2.5.0
    DesignStudio 1.5.3

    what i did is:

    Step1: Choose blank template
    Step2: Establish JNDI connection using the SampleData database and follow the query based on the screenshot
    Step3: skipped.. I was automatically directed to step 4
    Steps 4, 5, 6: ... i just pressed the next button..
    Step7: Click the finish button..

    When I preview the report it shows all data from the table..

    Lastly, I published the report following Step5 on this site (http://www.nicholasgoodman.com/bt/bl...entaho/how-to/)...

    that's all!
    again, thank you for the response...

    mhiL

  6. #6

    Default Error: JFreeReport.ERROR_007

    Hello everyone!

    I also encountered the same error when trying to create and publish a report.

    I was just trying to publish a report from a temptable in MySQL using Report Designer 1.6.0308 on Windows platform. When I try to preview it, the report works just fine. However, I encounter the error when I try to view the published report in Pentaho.

    I also tried to view/run the .xaction file using the latest release of Pentaho Design Studio, but the error's still there.

    The xaction and xml files have been attached in case it is needed.

    Any help would be greatly appreciated. Thanks!

    -roy
    Attached Files Attached Files
    Last edited by roren; 09-14-2007 at 05:17 AM. Reason: Sorry I forgot to include the platform I'm using.

  7. #7
    Join Date
    May 2006
    Posts
    9

    Default

    As you are using Report Designer 1.6, are you using pentaho BI-Server 1.6 as well?
    I had the Problem with Designer 1.6 and Bi Server 1.2 GA.
    Upgrading to server version 1.6 RC1 resovled the Problem.

    Please tell me, if that works for you as well.

    And i'd be interested, if it is a bug or if you always should use the same version of server and client tools.
    Probably one out of the development team can answer this.

    best regards,
    Jörg

  8. #8

    Default SOLVED: JFreeReport.ERROR_0007

    After installing the latest release of Pentaho BI (1.6.0 RC2), the published report worked fine.

    There may have been a bug in the previous version that have been solved in the latest release.

    Thanks for the info.

    -roy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.