Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Can't connect to pentaho/jboss through network

  1. #1
    Join Date
    Apr 2007
    Posts
    27

    Default Can't connect to pentaho/jboss through network

    I have downloaded pentaho_demo_mysql5-1.6.0-RC2.820.tar.gz and i have everything up and running it seems. Except for 2 problems one i fixed by re-entering the users. For some reason the users in the provided sql were not allowed. I deleted them and re-entered them into the database with qoutes for instance instead of:
    grant all on hibernate.* to hibuser identified by 'password';
    I put:
    grant all on hibernate.* to 'hibuser'@'localhost' identified by 'password';
    Now though I can't seem to find the setting either in jboss or pentaho to allow external connections to the server. I already changed the web.xml base-url.

    My ports are open on the machines firewall.

    I even started up glassfish which uses 8080 since it was on the machine and i can connect to that as well as the older version of the demo 1.5.4 which uses jboss.

    There must be a different setting somewhere in RC2 1.6.0 release.

    Anyone have any ideas?

  2. #2
    Join Date
    Apr 2007
    Posts
    27

    Default Solved

    The binding address in jboss is not set. I don't know if this is intentional or a mistake on the behalf of the people at pentaho.

    It is easily fixed by adding some parameters to the start-pentaho.sh file or the .bat if you are in windows

    Look in the pentaho-demo folder for start-pentaho.sh
    Find the line "sh run.sh" and add onto this

    -b [your ip or hostname]
    Example

    sh run.sh -b 192.168.1.102
    Then save it and restart the pentaho server

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.