Hitachi Vantara Pentaho Community Forums
Results 1 to 16 of 16

Thread: Error loading Spoon.bat

  1. #1
    Join Date
    Jun 2007
    Posts
    138

    Default Error loading Spoon.bat

    Hi...


    I am not able to start Spoon.bat of Kettle-3.0.0-M2 (Zip,downloaded from Pentaho site.)

    The error is,

    "Main class not found...Spoon will exit now"

    I m using windows xp
    Regards,
    kedar.mehta@tcs.com ,
    Tata consultancies Ltd

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    ... KEEP directory structure.

    Regards,
    Sven

  3. #3
    Join Date
    Jun 2007
    Posts
    138

    Default Dir Structure....with attachment

    D:\kedar\kettle\kettle 3\Kettle-3.0.0-M2


    where as i m using Kettle-3.0.0-M2.zip fille.If needed,then plz see the image (files n folders structure...)
    Attached Images Attached Images   
    Last edited by kedar mehta; 09-20-2007 at 08:10 AM.
    Regards,
    kedar.mehta@tcs.com ,
    Tata consultancies Ltd

  4. #4
    Join Date
    May 2006
    Posts
    4,882

    Default

    And you still get the error?

    If you still get it... try unzipping spoon in a place where there's no space in any of the directories preceding it.

    Sven
    Last edited by sboden; 09-20-2007 at 08:53 AM.

  5. #5
    Join Date
    Jul 2007
    Posts
    247

    Default

    Again: check if you are using Java 1.5 at least.

    I got the same error when I tried to start spoon using Java 1.4.2, after updating to 1.5 everything worked fine


    Regards,
    Ben

  6. #6
    Join Date
    Jun 2007
    Posts
    138

    Default Error...

    I m using JAVA 1.5.0_0

    Means Its Java 5 only...

    One more thing I am having kettle 's old source -2.5 .
    But,I think There is nothing to uninstall..
    Last edited by kedar mehta; 09-20-2007 at 08:52 AM.
    Regards,
    kedar.mehta@tcs.com ,
    Tata consultancies Ltd

  7. #7
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Version 1.5.0 (or later) of Java is indeed required for PDI version 3.0.0 and up.

  8. #8
    Join Date
    Jun 2007
    Posts
    138

    Default error

    Should I try this,as Sven said...


    "try unzipping spoon in a place where there's no space in any of the directories preceding it."

    I m having JAVA 5,Though,l Its not working.
    Regards,
    kedar.mehta@tcs.com ,
    Tata consultancies Ltd

  9. #9
    Join Date
    May 2006
    Posts
    4,882

    Default

    Quote Originally Posted by kedar mehta View Post
    Should I try this,as u said...


    "try unzipping spoon in a place where there's no space in any of the directories preceding it."
    yes please

  10. #10
    Join Date
    Jun 2007
    Posts
    138

    Default Not working...

    Hi,Sven...

    I tried to unzipp it,

    in the place C:\Kettle-3.0.0-M2

    The folder gets automatically created .so there will be no more folders in that place.

    Else.i cudn't get your point...I can create folder any where...U plz suggest me teh structure...
    Regards,
    kedar.mehta@tcs.com ,
    Tata consultancies Ltd

  11. #11
    Join Date
    Jun 2007
    Posts
    138

    Default Downlaod again...

    I m downloading Software again...


    Let me try my luck...Upto now,I m not able to start Sppon.bat of kettle 3.0

    Thanx to alll....
    Regards,
    kedar.mehta@tcs.com ,
    Tata consultancies Ltd

  12. #12
    Join Date
    Jun 2007
    Posts
    138

    Default Error loading main class

    I m getting same error.I downlaoded the same version again.

    The error I m getting is, Main Class not found....

    May be, I m making some silly mistake ..

    (As I am able to use all the old version of kettle....(2.5 n all) )

    Please help me...I am eager to see the newer version of kettle..

    I m already having java 1.5 runtime...

    Sven,
    Please Ellaborate more abt that folder structure issue..I m not in hurry for the solution...But thing is that,we are using kettle 2.5 for our 4 modules n we have got new business line...some new modules n projects,
    Where we plan to use some good tool.May be we ll continue with kettle or some other some tool from Pentaho.


    Plz help me to install ketle 3.0...


    Thanx,to all of Pentaho family...
    Regards,
    kedar.mehta@tcs.com ,
    Tata consultancies Ltd

  13. #13
    Join Date
    May 2006
    Posts
    4,882

    Default

    I downloaded it again and for me everything works... possible problems I could see:

    1) wrong JDK version, for v3.0.0-X JDK 1.5 is required (at least)
    2) the directory structure in the zip file should be maintained, in the directory where unzip Kettle there should appear e.g. a directory lib and libext (among others)
    3) You put kettle in a directory where one of the parent directories has a ' ' (space) in the names. On windows this could affects some things.

    That's all the problems I ever came across... as a next test... grab someone elses computer and have them install Kettle.

    Regards,
    Sven

  14. #14
    Join Date
    Mar 2007
    Posts
    13

    Cool Java 5, really?

    I appreciate that you've communicated in this thread that Java 1.5 or greater is necessary for PDI 3.0.

    My question is where else is this info available?

    Admittedly, I may be a lunkhead, but I've looked in what I called the obvious places (http://kettle.pentaho.org/, Matt Caster's blog, the documents that came with PDI 3.0). Still not seeing it.

    What obvious thing did I miss?

    If this is my oversight, I apologize, but if it's a requirement that is obscure it might be helpful if it were to be made more prominent.

    It almost seems like inside-information.

    frethog
    Frethog's Beer Can Solar Heater:
    http://www.squidoo.com/beercansolarheater

  15. #15
    Join Date
    May 2006
    Posts
    4,882

    Default

    3.0 is still work in progress, so there's no big annoucement "requires Java 5" somewhere, and the docs in the 3.0 download are not all updated yet.

    But it's been mentioned several times in different places. E.g. http://forums.pentaho.org/showthread.php?t=56481

    The GA version will have a big "Requires Java 5" notice somewhere

    Regards,
    Sven

  16. #16
    Join Date
    Jun 2007
    Posts
    138

    Default

    1 )I tried it on other machine.2) with no space included.3) I m havin JDK 1.5.0_some version..On all the test machines.

    4)Directory structure is having no space

    D:\kedar\kettle\Kettle-3.0.0-M2

    Under that folder,
    I have Kettle s all folders.Like, lib libext sample pwd kettle.bat spoon.bat
    etc

    Matt is suggesting me to download the code n compile it.But I dont how can i do it on console...Or with Net Beans ...

    Can I get this software in Digital Media like CD or something...?i think,Problem is may be in downloading the same.

    (U can verify my JDK version from attached Pic..)
    Attached Images Attached Images  
    Regards,
    kedar.mehta@tcs.com ,
    Tata consultancies Ltd

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.