Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Transaction Execution History not showing in Jboss server application

  1. #1

    Default Transaction Execution History not showing in Jboss server application


    Again i am facing a problem while integrating kettle to a Jboss server web application to add/execute the transformations or jobs through web.

    I am passing a valid log connection for the log table to kettle transMeta or jobMeta to log the execution history details. But unfortunately no history log entries are logged in the log table. I even could not find any error in the log.

    I tried to debug the code and was successful in going to the piece of code where actual history log writing takes place. There too kettle did not give any error but still the log entries are not created in DB.

    I have checked that the log table has all permissions. Any idea where the things are getting wrong? Please help!!

  2. #2

    Default Issue Solved. Problem is INNODB nature of log table in MySQL

    The issue is resolved. When i change the log table type to MYISAM in MySql from INNODB then it works fine. With table nature of INNODB, the log table connection does not create entries in the log table.

    I think this is a kettle bug. The log table history details should work for both MYISAM and INNODB table types.

  3. #3
    Join Date
    Nov 1999


    If you really think it's a bug, please file a bug report. Please also report the version of Kettle and the version of MySQL that you're using and any other information that will help us to verify this problem ourselves.

    Thanks in advance,


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.