Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Exception with Virtual cube in schema

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Exception with Virtual cube in schema


    i have the schema with 2 shared dimensions used in two distinct cubes (see bellow).
    Name:  cube.jpg
Views: 139
Size:  59.1 KB
    The schema is working fine with this MDX :

    select {[Measures].[montant_brut]} ON COLUMNS,
    {examen_ocean.type.MEMBERS} ON ROWS
    from [depenses]

    I want to join these two cubes into a virtual cube named v_depenses in my schema.

    But i have the following exception when i run the previous MDX :

    mondrian.olap.MondrianException: Mondrian Error:Internal error: could not find measure 'montant_brut' in cube 'depenses'

    mondrian.olap.MondrianException: Mondrian Error:Internal error: could not find measure 'montant_brut' in cube 'depenses'
    at mondrian.resource.MondrianResource$_Def0.ex(
    at mondrian.olap.Util.newInternal(
    at mondrian.rolap.RolapCube.(
    at mondrian.rolap.RolapSchema.load(
    at mondrian.rolap.RolapSchema.load(
    at mondrian.rolap.RolapSchema.(
    at mondrian.rolap.RolapSchema.(
    at mondrian.rolap.RolapSchema$Pool.get(
    at mondrian.rolap.RolapSchema$Pool.get(
    at mondrian.rolap.RolapConnection.(
    at mondrian.rolap.RolapConnection.(
    at mondrian.olap.DriverManager.getConnection(
    at com.tonbeller.jpivot.mondrian.MondrianModel.initialize(
    at com.tonbeller.jpivot.olap.model.OlapModelDecorator.initialize(
    at com.tonbeller.jpivot.tags.OlapModelProxy$MyState.initialize(
    at com.tonbeller.jpivot.tags.StackStateManager.initializeAndShow(
    at com.tonbeller.jpivot.tags.OlapModelProxy.initializeAndShow(
    at com.tonbeller.jpivot.tags.OlapModelTag.doEndTag(
    at org.apache.jsp.WEB_002dINF.queries.mondrian_jsp._jspService(

    Any Ideas ?


  2. #2
    Join Date
    Oct 2007

    Default asdf

    Well, better late than never, hope you figured it out, but for the sake of others who may run into this issue (and you if you haven't solved it):

    When constructing the virtual cube and adding measures, be sure you specify the qualified schema name for a measure. For example, if a cube contains the measure "monies", when adding the measure to your virtual cube it would look like this:

    <VirtualCubeMeasure cubeName="The Cube" name="[Measures].[monies]" visible="true">

    ... note that I gave as a name for the measure [Measures].[monies], not just monies.


  3. #3
    Join Date
    Feb 2008


    Wow....Brian thought he was late, but here I am three and a half years latter thanking him!!!

    Thank you so very much for you belated post!!! Saved me some serious time today.

  4. #4
    Join Date
    Mar 2012


    I'm facing the same problem as you.

    Would you suggest another thing to check/verify?
    Because I've already followed Phantal's suggestion but the exception is still there

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.