Hitachi Vantara Pentaho Community Forums
Results 1 to 7 of 7

Thread: HelloWorld.xaction SolutionEngine.ERROR_0005

  1. #1
    Join Date
    Sep 2007
    Posts
    4

    Unhappy HelloWorld.xaction SolutionEngine.ERROR_0005

    I am trying to understand pentaho,
    However with the demo I keep getting the following error whenever I try to view the HelloWorld script.
    The pentaho server does start and run.
    Any help would be greatly appreciated.

    FailedError: SolutionEngine.ERROR_0005 - Action sequence not valid (org.pentaho.core.solution.SolutionEngine)Debug: Starting execute of samples/getting-started/HelloWorld.action.xml (org.pentaho.core.solution.SolutionEngine)
    Debug: Getting runtime context and data (org.pentaho.core.solution.SolutionEngine)
    Debug: Loading action sequence definition file (org.pentaho.core.solution.SolutionEngine)
    Error: SolutionEngine.ERROR_0005 - Action sequence not valid (org.pentaho.core.solution.SolutionEngine)

    Server Version: Pentaho BI Platform 1.6.0-RC2.820

  2. #2
    Join Date
    Jun 2005
    Posts
    115

    Default

    Is there any more of a stack trace with this error?

  3. #3
    Join Date
    Sep 2007
    Posts
    4

    Default

    I wish there was, but that is all I get, in the JBoss window and in the server.log file. Is there a way to crank up the log level at all ?

  4. #4
    Join Date
    Jun 2007
    Posts
    50

    Red face

    This has occurred on occasion when the action sequence version might not be compatible with the BI Platform.

    Try downloading the latest version of the software which is now 1.6 GA.

    I have tried this and do not receive the error.

    http://localhost:8080/pentaho/ViewAc...oWorld.xaction

    Regards,

    Mike

    Look for the server.log file in the \pentaho-demo\jboss\server\default\log for more information. If that does not work.

  5. #5
    Join Date
    Sep 2007
    Posts
    4

    Default

    Bingo
    Slight differenece

    Works
    Code:
    http://localhost:8080/pentaho/ViewAction?&solution=samples&path=getting-started&action=HelloWorld.xaction
    Non working (from wiki page
    http://wiki.pentaho.org/display/Pent...ction+Sequence
    )
    Code:
    http://localhost:8080/pentaho/ViewAction?&solution=samples&path=getting-started&action=HelloWorld.action.xml
    Sorry,
    z

  6. #6
    Join Date
    Oct 2006
    Posts
    817

    Default

    Is there documentation that needs a correction?

  7. #7
    Join Date
    Sep 2007
    Posts
    4

    Default

    The written documentation is correct, but the link has a .xml after the helloWorld.xation, clicking on it gives you the error and you assume it is not working

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.