Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Refreshing Seems to require a restart

  1. #1

    Default Refreshing Seems to require a restart

    Hi

    Whenever I edit any of the .xml files in the pentaho-solutions directy, the olnly way to get the changes to take effect seems to be to stop and restart the entire BI Platform. This takes a minute or two, and can be frustrating for the other developers.

    Is there a quicker way?

    I have tried the 'admin' options of 'system settings' and 'update solution repository' but that does not seem to work.

    Any tips? Obvious things Im missing?

    Regards
    --Cor

  2. #2
    Join Date
    Aug 2007
    Posts
    151

    Unhappy Refreshing Seems to require a restart - for me too!!

    Hi,


    It also happens to me too. I couldn't figure out how to refresh without restarting the whole PCI, and the admin tool didn't work either.

    []s,


    Fábio

  3. #3
    Join Date
    Jun 2005
    Posts
    115

    Default

    Are you using the RDBMS or file based repository?

  4. #4
    Join Date
    Jul 2007
    Posts
    2,498

    Default

    You need to use file based repository and make sure pentaho.xml file has the option for file caching turned off
    Pedro Alves
    Meet us on ##pentaho, a FreeNode irc channel

  5. #5
    Join Date
    Aug 2007
    Posts
    151

    Default

    Thanks again, PMAlves! ;-)

  6. #6

    Default

    in pentaho.xml it has the following:

    <solution-repository>
    <!-- Insert solution-repository -->
    <cache-size>0</cache-size>
    </solution-repository>


    is that correct?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.