Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Hide steps

  1. #1

    Default Hide steps

    I hid some steps in one of my transforms and now I cannot figure out how to unhide these steps. How do I unhide these steps?

    Gerry

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    Drag them again from the main tree on the left hand side.

    Regards,
    Sven

  3. #3

    Default

    That is not intuitive! I was hunting on every menu and right-click for the Unhide. Can we get Unhide added to the right-click in the left menu selection? That would make it obvious.

    And I tried options in the right-click menu in the left menu pane and one of these was Share. Then I finally tried Delete. But now when I run my transforms I see this:
    2007/10/13 11:46:21 - SharedObjects - Reading the shared objects file [file:///home/greno/.kettle/shared.xml]
    2007/10/13 11:46:21 - StepMeta() - looking for the right step node (Socket reader)

    Socket reader is what I had shared and then deleted and now this SharedObjects still thinks it is there. How can I fix this?

    Gerry

  4. #4
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    At the moment you can't un-share shared objects.
    The reason for that is obvious: unlike with a shared repository, you can't tell in which transformation or job the object is being used.
    As such, we don't offer the option yet.

    If you want it gone, edit the shared.xml file.

    Matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.