Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Trouble with “Get File Names” step.

  1. #1

    Default Trouble with “Get File Names” step.

    I am trying to make a simple transformation parameter driven by starting the transformation with a Get File Names step to find the file to be loaded from a directory. The transformation works fine when I explicitly defined the file name in the “Read data from Text file” step.

    While setting up the Get File Names step, the "Show file name" button shows the file that I am expecting to be read but when I run the transformation the name is not being read and passed to the following step.

    What am I doing wrong? My transformation and execution log are attached.
    Attached Files Attached Files

  2. #2

    Smile

    try this :-)
    Last edited by shassan2; 03-27-2008 at 06:02 AM.

  3. #3

    Default

    In text file input, you have to fill "Field in the input to use as filename".

    In your "Look for done files", the filename is contain in the field named "filename".
    (to see right click on the step and select "Show output fields").

    Rgds

    Samatar
    Last edited by shassan2; 03-27-2008 at 06:02 AM.

  4. #4

    Default The filename field [ filename] could not be found

    Fellows thanks for the reply but I am still not getting the file name.

    When I right-click on the "Get File Name" step, I DO see "filename" listed as one of the output fields; but for some reason it is not found in the following step.

    I reattached the updated transformation for reference.

    THANKS!!!!

    ERROR MESSAGE:
    2007/10/17 12:39:43 - Look for done files.0 - Finished processing (I=0, O=0, R=0, W=1, U=0, E=0)
    2007/10/17 12:39:43 - MoneyPennyExtract .0 - ERROR (version 3.0.0-M2, build 252004 from 2007/09/06 01:03:58) : The filename field [ filename] could not be found in the input rows.
    Attached Files Attached Files
    Last edited by wburrell; 10-17-2007 at 12:47 PM. Reason: adding transformation

  5. #5
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    I detect a space in front of "filename" --> [ filename] and not [filename]
    Perhaps that has something to do with it.

    We actually give warnings for that sort of thing during transformation verify IIRC.

  6. #6

    Default

    THANKS!!! A preceding space was the problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.