Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Problem executing a transformation

  1. #1

    Default Problem executing a transformation

    Hi All,

    I am new to kettle please bear with my ignorance.

    I have configured the database to connect to Oracle, and did a simple table dumo from one table to other table. Application gives me the following error , saying

    2007/10/22 22:43:38 - DVS_CENTER_RAJU.0 - Running on slave server #0/1.
    2007/10/22 22:43:38 - RajuStaging - New database connection defined
    2007/10/22 22:43:42 - RajuStaging - Connected to database.
    2007/10/22 22:43:42 - RajuStaging - launch DDL statement:
    2007/10/22 22:43:42 - RajuStaging - set sql_mode := ''
    2007/10/22 22:43:42 - DVS_CENTER.0 - ERROR (version 3.0.0-RC1, build 299003 from 2007/10/01 23:14:52) : An error occurred, processing will be stopped:
    2007/10/22 22:43:42 - DVS_CENTER.0 - ERROR (version 3.0.0-RC1, build 299003 from 2007/10/01 23:14:52) : Error occured while trying to connect to the database
    2007/10/22 22:43:42 - DVS_CENTER.0 - ERROR (version 3.0.0-RC1, build 299003 from 2007/10/01 23:14:52) :
    2007/10/22 22:43:42 - DVS_CENTER.0 - ERROR (version 3.0.0-RC1, build 299003 from 2007/10/01 23:14:52) : Couldn't execute SQL: set sql_mode := ''
    2007/10/22 22:43:42 - DVS_CENTER.0 - ERROR (version 3.0.0-RC1, build 299003 from 2007/10/01 23:14:52) :
    2007/10/22 22:43:42 - DVS_CENTER.0 - ERROR (version 3.0.0-RC1, build 299003 from 2007/10/01 23:14:52) : ORA-00922: missing or invalid option





    When i configured my database and tested the connection it was not giving this error. But now when i tried to edit the connection and test the connection , it gives me a similar error. Saying cannot execute set sql_mode :=''. Can some one explain, what is the mistake i have done?

    Regards,
    Raju

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    See what's in the SQL tab of your database connection in Kettle. If something is in there, remake the connection. If it still doesn't go away, let us know.

    Regards,
    Sven

  3. #3

    Default

    The sql tab has set sql_mode:= '' . I removed this and tested the DB connection. It said connection successful. And executed the transformation, application could successfully load the table. Thanks a lot for your help.

    Regards,
    Raju

  4. #4
    Join Date
    May 2006
    Posts
    4,882

    Default

    Now make a new connection and see whether you still get the same problem. If you do it's a bug in Kettle, but I doubt it.

    Regards,
    Sven

  5. #5

    Default

    I am getting the same error. I can create a new PostgreSQL connection, and when I press the Test button on the Database Connection window, it says its OK. But as soon as I close the Database Connection form, and return to the Table Output form, pressing the SQL button generates the error: "Couldn't execute SQL: set sql_mode := "
    So I cannot get to the SQL tab to remove the sql_mode. Any suggestions?
    thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.