Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: PDI version 2.5.2 is available

  1. #1
    Join Date
    Nov 1999
    Posts
    9,729

    Thumbs up PDI version 2.5.2 is available

    Dear Kettle fans,

    A lot of things have happened in terms of development in the the 3.x codebase.
    However, that doesn't mean we don't maintain the 2.5 tree anymore. A lot of fixes where back-ported from the 3.x tree and we managed to add a few new job entries as well.
    Click here for a full list of the changes versus 2.5.1. A version 2.5.3 source tree has been opened in which we will continue to fix problems, at least for a while longer. We will no longer add new features to this version.

    Grab the goodies over here:

    Binary: Kettle-2.5.2.zip
    Source: Kettle-src-2.5.2.zip
    Windows installer: PDI-2.5.2.exe

    Instructions on how to install using the executable are over here. Just make sure to use a Microsoft Windows operating system to install on. :-)

    Version 2.5.2, like before runs on version 1.4 or higher of the Java Runtime Environment.

    Enjoy the release!

    Best regards,

    Matt
    Last edited by MattCasters; 06-11-2009 at 08:43 AM. Reason: typo fix

  2. #2
    Join Date
    Mar 2007
    Posts
    24

    Unhappy Mac OSX Leopard 10.5.2

    Hi Matt,

    This version does not seems to work on Mac OSX Leopard 10.5.2. It starts up, I can open existing transformation with it, but drag/drop of additional components to the 'canvas' is not working. It will simply not pick up the step.

    What is wrong here?

    I downloaded Kettle 2.5.2 (zip).

    With kind regards,
    Sander

  3. #3
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    "Leopard" broke so many things in Eclipse and SWT it's not even funny anymore.
    For example, have a look at this bug report :

    If you want to help out, try to replace file swt.jar found in this zip archive in libswt/osx.
    I can't test it myself, so you will have to file bug reports with feedback. (preferably a little bit more detailed :-))

    Cheers,
    Matt

  4. #4
    Join Date
    Mar 2007
    Posts
    24

    Default

    Hi Matt,

    I will try the SWT library you suggested and keep you posted. If I could have given more detail, I would have, but I did not get any error messages or crashed whatsoever. It just did not work...

    Regards,
    Sander

  5. #5
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Sander,

    We updated the SWT libs in version 2.5.3.
    You can try one of the nightly builds to see if this solves your Leopard problem:

    ftp://download.pentaho.org/client/da...gration/2.5.3/

    All the best,

    Matt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.