Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Java OutOfMemoryError - running a published report - Windows XP

  1. #1
    Join Date
    Oct 2007
    Posts
    5

    Default Java OutOfMemoryError - running a published report - Windows XP

    I am trying to run the Pentaho system on Windows XP.

    I have been able to use Report Designer to create a few reports and I have "published" them to a Solutions subdirectory. I can Preview the reports from the Report Designer. However, when I try to run any of them by selecting the report from the Solutions subdirectory through the Pentaho web page, I get the memory error in Java.

    I found the following in the run.bat file that start-pentaho.bat runs:

    set JAVA_OPTS=%JAVA_OPTS% -Xms128m -Xmx512m -XX:MaxPermSize=256m

    I changed the MaxPermSize to 512m, but there was no change in bahavior.

    Is this change enough? Is there somewhere else I should change as well?

    I had changed a similar statement in startdesigner.bat.

    As a step in debugging, I tried to capture the output that start-pentaho.bat spews to the screen, by running it in cmd mode

    start-pentaho.bat > log.txt

    This created an empty log.txt but still sent all output to the screen. I also tried 1>log.txt and also
    2>log.txt

    Does anyone know how to capture this output stream?

  2. #2
    Join Date
    Mar 2007
    Posts
    216

    Smile

    Hi,

    Quote Originally Posted by mcichelli View Post
    (...)Is there somewhere else I should change as well?(...)
    I have read somewhere that the -Xms parameter could be changed to higher value in case of OutOfMemoryError.
    Does anyone know how to capture this output stream?
    I have only a workaround for you : once the command line window is opened, right click it's title bar, select properties, tick the 2 boxes under Edit option : Fast Edit Mode and insert Mode. Click ok and tick "Save the properties for all futur window with the same title". Click ok.
    From there you shoud be lable to select text in he comtmand line window and Ctrl+C (copy), then Ctrl+V (paste) it where you want.

    a+, =)
    -=Clément=-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.