Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Launching Kettle in Linux

  1. #1
    Join Date
    Jan 2007
    Posts
    18

    Default Launching Kettle in Linux

    Hi

    I deployed Kettle2.5.2 in Slackware platform with JRE1.6.0_03. However, when I launch spoon like
    $sh spoon.sh, I get the following error:

    user@server:~/Kettle-2.5.2$ sh spoon.sh
    Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-pi-gtk-3333 or swt-pi-gtk in swt.library.path, java.libary.path or the jar file
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:219)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:151)
    at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:22)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
    at org.eclipse.swt.widgets.Display.<clinit>(Display.java:128)
    at be.ibridge.kettle.spoon.Spoon.main(Spoon.java:7111)

    Please advise
    Thanks
    Joe

  2. #2
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    64-bit? Install/use a 64-bit JRE?

  3. #3
    Join Date
    Jan 2007
    Posts
    18

    Default Resolved

    This issue was related to X11 forwarding; this has been fixed after X11 forwarding is fixed.

    Thanks

  4. #4
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    Really? I would very much like to learn more about that problem.

  5. #5
    Join Date
    Jan 2007
    Posts
    18

    Default

    I was launching Kettle remotely through x11 forwarding using SSH tunneling. When there was a problem with X11 forwarding, I was getting that error, and after that issue was resolved, it worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.