Hitachi Vantara Pentaho Community Forums
Results 1 to 10 of 10

Thread: Spoon 3.0.0 won't start on Vista (32-bit)

  1. #1

    Question Spoon 3.0.0 won't start on Vista (32-bit)

    I just upgraded to Spoon 3.0.0 and am Running Vista Business and the Spoon.bat file fails to launch. The .bat file window displays very breifly but Spoon never launches. Has anyone seen this issue? Any ideas on possible causes?

    Any Help is greatly appreciated!

    Thanks,
    J

  2. #2
    Join Date
    Jun 2007
    Posts
    476

    Default

    Check if this thread may help you:

    http://forums.pentaho.org/showthread.php?t=58239

  3. #3

    Default

    Unfortunately no. I came across this thread prior to posting. I cannot get the interface to load and hence cannot even get to a transformation.

    Thanks.
    J

  4. #4
    Join Date
    Jun 2007
    Posts
    476

    Default

    Try what sven said about the .bat file, with that you can see what is going on in the command prompt when starting spoon:

    Quote Originally Posted by sboden View Post
    When on windows look in directory "Documents and Settings\userid\Local Settings\Temp" for spoon* files.

    Else in spoon.bat change javaw in java, remove "start" from the same line and end the script with "pause"

    Regards,
    Sven

  5. #5

    Default

    Edited .bat file as Sven suggested and at the cmd prompt I get the following:

    Error occurred during initialization of VM
    java/lang/NoClassDefFoundError: java/lang/Object

    I then looked up this error and tried reinstalling the latest Java Update JRE6 Update3. I ran Spoon.bat again at cmd propmpt and received the following error:

    2007/11/27 16:47:26:613 MST [INFO] DefaultFileReplicator - Using "C:\Users\JBALEN~1\AppData\Local\Temp\vfs_cache" as temporary files store.
    ERROR 27-11 16:47:27,865 (LogWriter.javarintln:400) -Spoon - Fatal error : java.lang.NoClassDefFoundError: be/ibridge/kettle/job/entry/JobEntryInterface
    ERROR 27-11 16:47:27,869 (LogWriter.javarintln:400) -Spoon - java.lang.NoClassDefFoundError: be/ibridge/kettle/job/entry/JobEntryInterface
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$000(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at org.pentaho.di.core.PDIClassLoader.loadClass(PDIClassLoader.java:38)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at org.pentaho.di.core.plugins.PluginLoader.fromXML(PluginLoader.java:40
    7)
    at org.pentaho.di.core.plugins.PluginLoader.build(PluginLoader.java:293)
    at org.pentaho.di.core.plugins.PluginLoader.doConfig(PluginLoader.java:1
    88)
    at org.pentaho.di.core.plugins.PluginLoader.load(PluginLoader.java:127)
    at org.pentaho.di.job.JobEntryLoader.readPlugins(JobEntryLoader.java:136
    )
    at org.pentaho.di.job.JobEntryLoader.init(JobEntryLoader.java:97)
    at org.pentaho.di.ui.spoon.Spoon.createSpoon(Spoon.java:5246)
    at org.pentaho.di.ui.spoon.Spoon.run(Spoon.java:5590)
    at org.pentaho.di.ui.spoon.Spoon.main(Spoon.java:357)

    This looks similar to issues on referenced thread;

    http://forums.pentaho.org/showthread.php?t=58239

    I will check back on that thread tomorrow. If anyone comes up with anything in the mean time, please share ;-)

    Thanks,
    J
    Last edited by jbalentine; 11-27-2007 at 07:57 PM.

  6. #6

    Default

    type "java -version" in cmd.exe windows, you can get the java vm version which used in your env default.

  7. #7

    Default

    Current version of Java;

    java version "1.6.0_03"
    Java(TM) SE Runtime Environment (build 1.6.0_03-b05)
    Java HotSpot(TM) Client VM (build 1.6.0_03-b05, mixed mode, sharing)

    J

  8. #8

    Default

    The culprit here appears to be the following error;

    -Spoon - Fatal error : java.lang.NoClassDefFoundError: be/ibridge/kettle/job/entry/JobEntryInterface

    How/where do I look to properly define this class??

    Thanks,
    J

  9. #9
    Join Date
    Nov 1999
    Posts
    9,729

    Default

    That class belongs to version 2.x of PDI. It is no longer in use nor supported in version 3.
    Perhaps you are mixing and matching versions?

    Try to uninstall and re-install your Kettle distribution (PDI-3.0.0.exe) or to unzip the zip file (Kettle-3.0.0-GA.zip) in a new directory.

    Matt

  10. #10

    Default

    Thank you Matt,

    I simply unzipped 3.0 into a new directory and all is well.

    Thank you for the assistance!

    J

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.