Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Issue with text file input

  1. #1
    Join Date
    Dec 2007
    Posts
    7

    Post Issue with text file input

    I've come across a weird problem when using Text File Input.
    The text file I'm trying to import uses the Null if property, and the null value is null. See the example below. null if is set to null on Current_YN and Active_YN

    If I attempt to preview rows, or run the transformation a strange thing happens to the data. The columns that have the null if property behave as if they have a null value if the first character in an N.

    Input file

    Code:
     
    Direction  Current_YN  Active_YN
    North"            "Y"          "N"
    "South"           "N"          "Y"
    "East"            "null"        "null"
    "West"            "N"           "N"
    Output - writing to a text file is

    Code:
     
    Direction  Current_YN  Active_YN
    North"            "Y"          
    "South"                       "Y"
    "East"         
    "West"
    This can also be repeated setting the null if value to bull and
    substituting a B for the N values, same result. I've replicated this in 3.0.GA and 3.0.1. This is a nasty bug and has caused me some real problems. I've not been able to work around it and I"m not able to change the data. Any ideas. I've attached the transformation and a sample input file that reproduces the problem


    Also, found another problem in 3.0.GA. If you use a variable for a schema name in a database lookup and try to look at any components downstream, the component you're trying to open will throw an error.

    Thanks,

    Bob
    Attached Files Attached Files

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    Raise a JIRA at http://jira.pentaho.org/browse/PDI include your example.

    For the downstream exceptions: when you get fields the request gets pushed down until it hits something it can work with, if this is a database step and use variables which are not filled in you will get an exception. Set the variable right and it should be ok.

    Regards,
    Sven
    Last edited by sboden; 12-05-2007 at 03:16 AM.

  3. #3
    Join Date
    Dec 2007
    Posts
    7

    Default

    In regards to the database lookup using a variable for the lookup schema. I do have the variable set and the transformation runs correctly, I seems not to resolve itself when any components in the transformation are referenced. It doesn't matter if it is the default schema my id is associated with, or a schema I have access rights to.


    If you put a literal into the target schema field, it will resolve correctly.

    Thanks,

    Bob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.