Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: how to connect to database MySQL

  1. #1
    Join Date
    Dec 2007
    Posts
    4

    Angry how to connect to database MySQL

    Hi, I'm really new to Pentaho and I started to see it a few weeks ago.

    I had a lot of troubles in connecting my MySQL database by JNDI.

    I tried to insert all the required info:
    - name: connectMySQL
    - connection url: jdbc:mysql://localhost/PentahoDB
    - driver: com.mysql.jdbc.Driver
    - username: root
    - psw: <my password of MySQL user>

    both MySQL and Pentaho are on the same machine;
    PentahoDB is the name of DB which I want to get data from.

    The exact message error when I hit the "Test" button of the connection is "The message returned was socket creation error"

    I really don't understand the problem.

    The major point is that with the same configuration I have already connect this database to Spoon, so the problem is not in the database...

    Please, help ME!!!!!

    thank u very much

    Cristiano
    Last edited by cghersi; 12-05-2007 at 04:22 PM. Reason: adding exact message error

  2. #2
    Join Date
    Apr 2008
    Posts
    10

    Default

    i am also having this issue

  3. #3

    Default

    not to state the obvious but do check to see if mysql is actually running, and connecting by the mysql client software actually works. And if they both work check out http://dev.mysql.com/doc/refman/5.0/...to-server.html
    This is a signature.... everyone gets it.

    Join the Unofficial Pentaho IRC channel on freenode.
    Server: chat.freenode.net Channel: ##pentaho

    Please try and make an effort and search the wiki and forums before posting!
    Checkout the Saiku, the future of Open Source Interactive OLAP(http://analytical-labs.com)

    http://mattlittle.files.wordpress.co...-bananaman.jpg

  4. #4
    Join Date
    Jun 2008
    Posts
    6

    Default

    If you are sure that your mysql is running, and it is running at 3306 port, it is very weird to have a socket problem, you could also try to put 127.0.0.1 , or your eth0 or lan IP instead of localhost, and it could be very interesting to check if your mysql configuration file (my.cnf) do not have the option "skip networking" uncommented (without a # at de beggining of the line) or in later releases the option networks without your lan network.

    hope it helps

    J

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.