Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Unable to run pentaho-demo

  1. #1
    Join Date
    Dec 2007
    Posts
    2

    Question Unable to run pentaho-demo

    Hello Guys,

    I tried to install pentaho-demo, but unfortunately the application doesn't run. Every time I run "start-pentaho.sh", the application server had never went up.
    I'm using a virtualized machine, a linux opensuse 10.2 64 bits edition, the server is a Dell Poweredge with AMD Opteron 64 as processor and have java SDK EE 1.5 installed (I configured the JAVA_HOME in the system path).
    The server has 768MB RAM and 1.5 Gb of swap.
    Attached you'll find the logs.


    Thank you very much in advance for your help.
    Attached Files Attached Files

  2. #2
    Join Date
    Nov 2005
    Posts
    164

    Default

    Hello juancm_mx,

    The logs indicate that your JVM has run out of memory:

    2007-12-07 11:58:16,824 ERROR [STDERR] Caused by: java.lang.OutOfMemoryError: unable to create new native thread

    Is there any way you can allocate more actual memory for your virtual machine?

    - Brian Hagan
    Pentaho Build / Suppor Engineer

  3. #3
    Join Date
    Oct 2006
    Posts
    817

    Default

    It might be that BirtSystemListener is to blame for the out-of-memory error. Try disabling it by commenting it out in pentaho-solutions/system/pentaho.xml. If it runs fine without BirtSystemListener, then you can focus your energy on fixing that listener.

    Code:
    <!-- delete or comment out the line below -->
    <birt>org.pentaho.plugin.eclipsebirt.BirtSystemListener</birt>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.