Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Problem with Merge Join and Jfreereport

  1. #1
    Join Date
    Oct 2007
    Posts
    18

    Default Problem with Merge Join and Jfreereport

    I am having a problem with merge join in Kettle 3.0.0 GA. I want to create
    a Kettle transform that will join together the result sets from two queries,
    where each query accesses a different database. I then want to feed the
    result set from the Kettle transformation into a Jfreereport.

    I have managed to successfully hook together a Kettle transform and
    Jfreereport (based on a sample in the PCI). However, when the transform
    uses a merge join, then I have problems. Specifically, the Jfreereport
    behaves as if the input fields are not present, and these error messaages
    are generated:

    [JCommon] Warning: Data-Set does not contain a column with name 'LASTNAME'
    [JCommon] Warning: Data-Set does not contain a column with name 'CITY'

    Attached is an example of the problem, which runs in the PCI. (I've tried
    it in Pentaho 1.6.1.903 and 1.7.0.930 with same result.) To keep things
    simple, this example merges two result sets from the same database
    (sampledata), but the same problem occurs when using two databases.

    In the attachment, the report driven by kettle_no_mergejoin.xaction gets its
    results from a Kettle transform that does not involve merge join, and it works
    correctly. The report driven by kettle_mergejoin.xaction gets its results from
    the merge join step of a Kettle transform, and produces blank output.

    Other than the transform used, the two reports are identical. Is this
    a bug or am I missing something?

    Regards,
    Larry
    Attached Files Attached Files
    Last edited by larrybennett; 12-04-2007 at 06:57 AM. Reason: Clarify

  2. #2
    Join Date
    Oct 2007
    Posts
    18

    Default

    I've resolved this issue now. It turns out that I was using
    the Kettle 2.5.1 that is included in the Pentaho platform 1.6/1.7.
    I upgraded Kettle to 3.0.0 using the instructions at:

    http://wiki.pentaho.org/display/EAI/...ntaho+platform

    Now the JfreeReport correctly gets the output of the Kettle
    transform.

    Regards,
    Larry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.