Hitachi Vantara Pentaho Community Forums
Results 1 to 12 of 12

Thread: Attach file to email not working

  1. #1
    Join Date
    Dec 2007
    Posts
    2

    Default Attach file to email not working

    Dear All,

    I need to attach an excel file to the email in the spoon job. But I didn't find any options to do so. There is attach file to message with options of 'General', 'Log', 'Error line', 'Error' and 'Warning'. But looks like they all log files generated by the kettle process. Does anyone know how to attach excel file to the email?

    Thanks in advance!

    czhu

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    You need to make an extra transformation with a get filenames step (selecting your file) and a put files to result step and use that in a job first calling that new transformation, and then your mail job entry.

    Regards,
    Sven

  3. #3
    Join Date
    Dec 2007
    Posts
    2

    Default

    It's working now!!! Thank you so much!!!

  4. #4

    Question Email attachment is not attaching the excel file

    Hi Sven/nwuser,

    I am in the same situation as nwuser that my email is not including the attachment. It simply sends out an email.

    I have a job with start step, transformation1 (with table input and excel output), transformation2 (with Get files from result and Set files in result), then the email component.

    When I run the job manually it attaches the excel file to the email. I have this job scheduled thru the Windows Scheduled tasks. When it runs at the specified time, it doesn't include the attachment.

    Could you please help? Please let me know if you need me to attach the job & transformations.

    Thanks and appreciate any help.
    Mani

  5. #5
    Join Date
    May 2006
    Posts
    4,882

    Default

    In the job step you probably clear the files.... but you can always attach them (after removing passwords, ...).

    Regards,
    Sven

  6. #6

    Default

    Hi Sven,

    I checked the transformation properties and none of the flags are checked for clear the result files or clear the result rows.

    You have mentioned, "but you can always attach them (after removing passwords, ...)". Could you please explain how I can attach them?

    Thanks for your help.
    Mani

  7. #7

    Default Files

    Hi Sven,

    Please find the attached files for your reference.

    Any help would be appreciated.

    Thanks,
    Mani
    Attached Files Attached Files

  8. #8
    Join Date
    Apr 2008
    Posts
    123

    Default

    I was able to get this working but am not able to select a specific file to send by mail. i.e. Transformation 1 generates 5 different files, but I do need to send 1 file to 1 person and another file to another person etc - not all five files to the same person......
    Last edited by roco; 01-09-2009 at 05:44 PM.

  9. #9
    Join Date
    Dec 2011
    Posts
    2

    Thumbs up

    Quote Originally Posted by maniramasamy View Post
    Hi Sven,

    Please find the attached files for your reference.

    Any help would be appreciated.

    Thanks,
    Mani
    Thanks....your expample was a great help!! +100!!!

  10. #10
    Join Date
    May 2013
    Posts
    2

    Default

    Hi all,
    First of all, glad to join this forum, it kind of usefull source for me to learn the pentaho.
    Now please allow me to share my problems..

    I believe i have the same issue like this thread subject, but slightly different.
    I try to look, but still can't find a proper solution.

    In my spoon transformation, i use PRD output files that successfully create a dynamic subject stream html files based on date whenever i run the transformation in a job, for example it has 30 kbyte size. then after that in the same transformation, i use email step to attach that html files. Right before the PRD Output step, i also add some modified JS and merge join to get various email address destination as variables to send to.
    But then the problems comes up... not all the receipent email address get that files, some people get 0 bytes, so it can't displayed in their email.
    I try to run the transformation 4 times in a row, the 0 bytes received occurs, but the receipent were different each times. seems like it has no consistency...
    Can some body help me out what i did wrong? thx very much in advance...

  11. #11
    Join Date
    Oct 2015
    Posts
    10

    Default

    Thank you Sven! I'm a novice user, your sample helped me a lot!
    Svetlana

  12. #12
    Join Date
    Jul 2016
    Posts
    1

    Default

    Hello,
    Thank you so mutch for your files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.