Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Problem getting filename field in Excel Input to work

  1. #1
    Join Date
    Jun 2007
    Posts
    23

    Default Problem getting filename field in Excel Input to work

    I'm new to Kettle and within a couple of hours was able to create a transformation reading from Excel, selecting a subset of the fields, normalizing the rows, and inserting to a mySQL table.

    I'd like to add the excel filename as a field, but when I populate the EXCEL INPUT-->CONTENT->FILENAME FIELD with a string, say "fileNameFld", I get no rows in the preview.

    When I remove the string, I get rows.

    Is there an extra step to this? Can somebody post a sample where this works?

    TIA

  2. #2
    Join Date
    May 2006
    Posts
    4,882

    Default

    Tried it on v3.0GA, works perfectly.

    Which version are you using and which error do you get in the log window?

    Regards,
    Sven

  3. #3
    Join Date
    Jun 2007
    Posts
    23

    Default I was using 3.0GA, got it working with some sample files...

    I was preparing a sample transformation to show but saw that it worked using 3.0GA. Having problems with "Unable to initialize" error with other Excel files. Now downloading 3.0.1...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.